net-proxy/haproxy: Add prometheus-exporter re bug 688350
authorChristian Ruppert <idl0r@gentoo.org>
Mon, 24 Jun 2019 13:03:24 +0000 (15:03 +0200)
committerChristian Ruppert <idl0r@gentoo.org>
Mon, 24 Jun 2019 13:03:44 +0000 (15:03 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.12
Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
net-proxy/haproxy/haproxy-2.0.0.ebuild
net-proxy/haproxy/metadata.xml

index e41593121e880dca7e423a3040de387c5a141914..3924975aade709a92e30b593c92effcedeaceb36 100644 (file)
@@ -20,8 +20,8 @@ fi
 
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
-IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
-systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
+IUSE="+crypt doc examples libressl slz +net_ns +pcre pcre-jit pcre2 pcre2-jit prometheus-exporter
+ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
 REQUIRED_USE="pcre-jit? ( pcre )
        pcre2-jit? ( pcre2 )
        pcre? ( !pcre2 )
@@ -98,8 +98,12 @@ src_compile() {
        # For now, until the strict-aliasing breakage will be fixed
        append-cflags -fno-strict-aliasing
 
+       if use prometheus-exporter; then
+               EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
+       fi
+
        # HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
-       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
+       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
        emake -C contrib/systemd SBINDIR=/usr/sbin
 
        if use tools ; then
index 6a09dde73e296a4d2548cbe1f156151c29467484..bb3436846b425301eb3765ab3d80e6ddca658b56 100644 (file)
@@ -23,6 +23,7 @@
                <flag name="pcre-jit">Use JIT support for PCRE</flag>
                <flag name="pcre2">Enable PCRE2 RegEx support</flag>
                <flag name="pcre2-jit">Use JIT support for PCRE2</flag>
+               <flag name="prometheus-exporter">Also build the prometheus exporter</flag>
                <flag name="slz">Use <pkg>dev-libs/libslz</pkg> compression library</flag>
                <flag name="tools">Install additional tools (halog, iprange)</flag>
                <flag name="device-atlas">Use <pkg>dev-libs/device-atlas-api-c</pkg> library</flag>