net-ftp/filezilla: add gnome2_icon_cache_update()
authorBernard Cafarelli <voyageur@gentoo.org>
Tue, 2 Jan 2018 09:07:02 +0000 (10:07 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Tue, 2 Jan 2018 09:07:13 +0000 (10:07 +0100)
Closes: https://bugs.gentoo.org/641018
Package-Manager: Portage-2.3.19, Repoman-2.3.6

net-ftp/filezilla/filezilla-3.25.2-r1.ebuild
net-ftp/filezilla/filezilla-3.25.2.ebuild

index 27a892849dad5092b0154806074b318b37c909d2..a39e198691d055bd317afa0a3ca03b358f9ae7c6 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 WX_GTK_VER="3.0-gtk3"
 
-inherit autotools eutils flag-o-matic multilib wxwidgets
+inherit autotools eutils flag-o-matic gnome2-utils multilib wxwidgets
 
 MY_PV=${PV/_/-}
 MY_P="FileZilla_${MY_PV}"
@@ -66,3 +66,11 @@ src_configure() {
                --with-pugixml=system \
                --disable-autoupdatecheck
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}
index 9273ca52e53c2206ac7004464373c171525eab02..61eb63e204bcf6e2c411f386ce825cf811e3f5c1 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 WX_GTK_VER="3.0"
 
-inherit autotools eutils flag-o-matic multilib wxwidgets
+inherit autotools eutils flag-o-matic gnome2-utils multilib wxwidgets
 
 MY_PV=${PV/_/-}
 MY_P="FileZilla_${MY_PV}"
@@ -66,3 +66,11 @@ src_configure() {
                --with-pugixml=system \
                --disable-autoupdatecheck
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}