dev-ruby/facter: add cap on boost, fails to build with newer boost
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Jul 2019 18:24:49 +0000 (13:24 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Jul 2019 18:24:56 +0000 (13:24 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-ruby/facter/Manifest
dev-ruby/facter/facter-3.12.3.ebuild [deleted file]
dev-ruby/facter/facter-3.12.4.ebuild [deleted file]
dev-ruby/facter/facter-3.13.0.ebuild [deleted file]
dev-ruby/facter/facter-3.13.2-r1.ebuild
dev-ruby/facter/facter-3.14.1.ebuild
dev-ruby/facter/facter-3.9.2-r1.ebuild

index 90b39bf1a1c4f87252287740dafe466e33b1f2ec..202f831e580c40ca832cef3debf4822418808d87 100644 (file)
@@ -1,6 +1,3 @@
-DIST facter-3.12.3.tar.gz 391836 BLAKE2B 60ec23ab9df0d6ca069608c897949be8aaf719b2ab1b71455871a9364b7d0111ec78753cdb45d082041d2b028bac8e468a415a2bd9a15fe51dc69ec9738dc723 SHA512 d1568ca606b07c67f2e293b020dc5c2d399d5080857e47d3c748a7d104f75231d59dc95d54e5504b24f951ce540d1223102ee1b882e4495633ed89324ccc1c7b
-DIST facter-3.12.4.tar.gz 392011 BLAKE2B 5e3d7ce65eb6c35cddba70b2b397cdc9c591a6c420a58a04ecddabdc537f0f799c510d14bba436aadbdce9c9932a28b6b36b893526a7727c8017c79827a97b9a SHA512 952bf1ac4c67bfb5170d31bca471c317211523804a14bd39f34b4fd0730586b3764499200b5c816d4b6bd0338482ea8bd83cedc5fe670db38ea6ec144b6e2e94
-DIST facter-3.13.0.tar.gz 391833 BLAKE2B 8fabb2ebb438975564a770657866c6ac8ac77394c4e3cdb635eae78a744a097ef5eabb4307092cd2b9cf12b4db70623b18b3ca1e2c9e1a248825a2bf53b76565 SHA512 f3c39239d7b0708bd98a3e5de5d5623406edf5e60b6321de1d4ec7c8cf903f3ec777640b9301979f2316e90e97e2aa0a80dc71975239dc715aaba61ec7cc37de
 DIST facter-3.13.2.tar.gz 392065 BLAKE2B ae06a1a44de25f55b2eb84483a7abc70433b9437a00724f239a908846148f20bdb3e208d10256e6ddeb7d609ee9eb1c572e14dad84d8640fee147c34cb1bf184 SHA512 c7d1d0958720e0884b06eccf6d7fca64d2c8462c1747bbfbfe5df957ad009c3e930fe5eee80d42c985ea9f59e2b8b7d0a34a194a7e1c713a043bbee9a3b89df3
 DIST facter-3.14.1.tar.gz 393548 BLAKE2B a3f61df9a7a302948fa8579c451b5cdb973a3e8b92109582b1a6046c68e5212b675f9310012409194f933574d004a7a3fbed1dc0e20576a2ee759feadeac54ee SHA512 b3f4cbaffb2c70423fd9d5eca7afdee35f92f3a3445fb78996258471a3dc3881b1797bed5ee90aa66b62b0e9d1b979dbc05b6e169499d4f1a9e61f002118476d
 DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
diff --git a/dev-ruby/facter/facter-3.12.3.ebuild b/dev-ruby/facter/facter-3.12.3.ebuild
deleted file mode 100644 (file)
index 6d48b1f..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
-       EGIT_BRANCH="master"
-else
-       [[ "${PV}" = *_rc* ]] || \
-       KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-BDEPEND="
-       >=sys-devel/gcc-4.8:*
-       dev-cpp/cpp-hocon"
-COMMON_DEPEND="
-       >=dev-libs/leatherman-1.0.0:=
-       dev-libs/openssl:0=
-       sys-apps/util-linux
-       app-emulation/virt-what
-       net-misc/curl
-       >=dev-libs/boost-1.54:=[nls]
-       >=dev-cpp/yaml-cpp-0.5.1
-       !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
-       ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
-       ruby-ng_pkg_setup
-}
-
-src_unpack() {
-       default
-
-       if [[ ${PV} == 9999 ]] ; then
-               git-r3_src_unpack
-       fi
-}
-
-src_prepare() {
-       # be explicit about the version of rspec we test with
-       sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
-               CMakeLists.txt || die
-       # be more lenient for software versions for tests
-       sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
-               -e '/rspec/ s/2.11.0/2.11/' \
-               -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
-       # patches
-       default
-       cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
-       # hack for correct calculation of relative path from facter.rb to
-       # libfacter.so
-       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
-       ruby-ng_src_configure
-
-       local mycmakeargs=(
-               -DCMAKE_VERBOSE_MAKEFILE=ON
-               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
-               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
-       )
-       if use debug; then
-               mycmakeargs+=(
-                 -DCMAKE_BUILD_TYPE=Debug
-               )
-       fi
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       addpredict /proc/self/oom_score_adj
-       cmake-utils_src_compile
-}
-
-src_test() {
-       cmake-utils_src_test
-}
-
-each_ruby_install() {
-       doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
-       cmake-utils_src_install
-       ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.12.4.ebuild b/dev-ruby/facter/facter-3.12.4.ebuild
deleted file mode 100644 (file)
index 6d48b1f..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
-       EGIT_BRANCH="master"
-else
-       [[ "${PV}" = *_rc* ]] || \
-       KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-BDEPEND="
-       >=sys-devel/gcc-4.8:*
-       dev-cpp/cpp-hocon"
-COMMON_DEPEND="
-       >=dev-libs/leatherman-1.0.0:=
-       dev-libs/openssl:0=
-       sys-apps/util-linux
-       app-emulation/virt-what
-       net-misc/curl
-       >=dev-libs/boost-1.54:=[nls]
-       >=dev-cpp/yaml-cpp-0.5.1
-       !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
-       ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
-       ruby-ng_pkg_setup
-}
-
-src_unpack() {
-       default
-
-       if [[ ${PV} == 9999 ]] ; then
-               git-r3_src_unpack
-       fi
-}
-
-src_prepare() {
-       # be explicit about the version of rspec we test with
-       sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
-               CMakeLists.txt || die
-       # be more lenient for software versions for tests
-       sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
-               -e '/rspec/ s/2.11.0/2.11/' \
-               -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
-       # patches
-       default
-       cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
-       # hack for correct calculation of relative path from facter.rb to
-       # libfacter.so
-       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
-       ruby-ng_src_configure
-
-       local mycmakeargs=(
-               -DCMAKE_VERBOSE_MAKEFILE=ON
-               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
-               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
-       )
-       if use debug; then
-               mycmakeargs+=(
-                 -DCMAKE_BUILD_TYPE=Debug
-               )
-       fi
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       addpredict /proc/self/oom_score_adj
-       cmake-utils_src_compile
-}
-
-src_test() {
-       cmake-utils_src_test
-}
-
-each_ruby_install() {
-       doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
-       cmake-utils_src_install
-       ruby-ng_src_install
-}
diff --git a/dev-ruby/facter/facter-3.13.0.ebuild b/dev-ruby/facter/facter-3.13.0.ebuild
deleted file mode 100644 (file)
index 6d48b1f..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-if [[ ${PV} == 9999 ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
-       EGIT_BRANCH="master"
-else
-       [[ "${PV}" = *_rc* ]] || \
-       KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-       SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-BDEPEND="
-       >=sys-devel/gcc-4.8:*
-       dev-cpp/cpp-hocon"
-COMMON_DEPEND="
-       >=dev-libs/leatherman-1.0.0:=
-       dev-libs/openssl:0=
-       sys-apps/util-linux
-       app-emulation/virt-what
-       net-misc/curl
-       >=dev-libs/boost-1.54:=[nls]
-       >=dev-cpp/yaml-cpp-0.5.1
-       !<app-admin/puppet-4.0.0"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="${COMMON_DEPEND}"
-DEPEND="${BDEPEND}
-       ${COMMON_DEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
-       ruby-ng_pkg_setup
-}
-
-src_unpack() {
-       default
-
-       if [[ ${PV} == 9999 ]] ; then
-               git-r3_src_unpack
-       fi
-}
-
-src_prepare() {
-       # be explicit about the version of rspec we test with
-       sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
-               CMakeLists.txt || die
-       # be more lenient for software versions for tests
-       sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
-               -e '/rspec/ s/2.11.0/2.11/' \
-               -e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
-       # patches
-       default
-       cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
-       # hack for correct calculation of relative path from facter.rb to
-       # libfacter.so
-       my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
-       ruby-ng_src_configure
-
-       local mycmakeargs=(
-               -DCMAKE_VERBOSE_MAKEFILE=ON
-               -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
-               -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
-       )
-       if use debug; then
-               mycmakeargs+=(
-                 -DCMAKE_BUILD_TYPE=Debug
-               )
-       fi
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       addpredict /proc/self/oom_score_adj
-       cmake-utils_src_compile
-}
-
-src_test() {
-       cmake-utils_src_test
-}
-
-each_ruby_install() {
-       doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
-       cmake-utils_src_install
-       ruby-ng_src_install
-}
index ebbe2255c46714c907e0c34f78aa5fc300508fc3..b9491751f31bc116d55cb06ad134fbe0a217071d 100644 (file)
@@ -33,6 +33,7 @@ COMMON_DEPEND="
        app-emulation/virt-what
        net-misc/curl
        >=dev-libs/boost-1.54:=[nls]
+       <dev-libs/boost-1.70.0
        >=dev-cpp/yaml-cpp-0.5.1
        !<app-admin/puppet-4.0.0"
 
index 41229ebb2d20723601d5499feb118e27e7798667..4c7110c0cf6d2ad3f1adf9b05a36f1fe531fb0d1 100644 (file)
@@ -33,6 +33,7 @@ COMMON_DEPEND="
        app-emulation/virt-what
        net-misc/curl
        >=dev-libs/boost-1.54:=[nls]
+       <dev-libs/boost-1.70.0
        >=dev-cpp/yaml-cpp-0.5.1
        !<app-admin/puppet-4.0.0"
 
index f23d657e2fee7ea368500cae45259c889814c62c..1c70dd61c8d8bcc3dc7f8e8aeeb763578eacccdc 100644 (file)
@@ -26,6 +26,7 @@ CDEPEND="
        app-emulation/virt-what
        net-misc/curl
        >=dev-libs/boost-1.54[nls]
+       <dev-libs/boost-1.70.0
        >=dev-cpp/yaml-cpp-0.5.1
        !<app-admin/puppet-4.0.0"