dev-scheme/gauche: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Mon, 5 Oct 2015 12:44:51 +0000 (14:44 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Mon, 5 Oct 2015 13:52:31 +0000 (15:52 +0200)
dev-scheme/gauche/gauche-0.9.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-scheme/gauche/gauche-0.9.4-r1.ebuild b/dev-scheme/gauche/gauche-0.9.4-r1.ebuild
new file mode 100644 (file)
index 0000000..dda1916
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+MY_P="${P^g}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://practical-scheme.net/gauche/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 libressl test"
+
+RDEPEND="sys-libs/gdbm"
+DEPEND="${RDEPEND}
+       test? (
+               !libressl? ( dev-libs/openssl:0 )
+               libressl? ( dev-libs/libressl )
+       )"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-rpath.diff
+       epatch "${FILESDIR}"/${PN}-gauche.m4.diff
+       epatch "${FILESDIR}"/${PN}-ext-ldflags.diff
+       epatch "${FILESDIR}"/${PN}-xz-info.diff
+       epatch "${FILESDIR}"/${PN}-rfc.tls.diff
+       eautoconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable ipv6) \
+               --with-slib="${EPREFIX}"/usr/share/slib
+}
+
+src_test() {
+       emake -j1 -s check
+}
+
+src_install() {
+       emake -j1 DESTDIR="${D}" install-pkg install-doc
+       dodoc AUTHORS ChangeLog HACKING README
+}