make sure selinux libs come last in linking #160879 by Peter Hjalmarsson
authorMike Frysinger <vapier@gentoo.org>
Fri, 30 Mar 2007 05:50:01 +0000 (05:50 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 30 Mar 2007 05:50:01 +0000 (05:50 +0000)
Package-Manager: portage-2.1.2.2

sys-apps/busybox/files/1.4.0/selinux-link.patch

index b2e69e4ac025a50a7e9d2a26ad397bf8baee9a27..ee5c645861de8f490ce63173034682551021b6a7 100644 (file)
@@ -1,3 +1,15 @@
+--- busybox-1.4.2/Makefile
++++ busybox-1.4.2/Makefile
+@@ -564,7 +564,8 @@
+       cmd_busybox__ ?= $(srctree)/scripts/trylink $(CC) $(LDFLAGS) \
+       -o $@ \
+       -Wl,--warn-common -Wl,--sort-common -Wl,--gc-sections \
+-      -Wl,--start-group $(busybox-all) -Wl,--end-group
++      -Wl,--start-group $(busybox-all) -Wl,--end-group \
++      $(LDLIBS)
+ # Generate System.map
+ quiet_cmd_sysmap = SYSMAP
 --- busybox-1.4.2/Makefile.flags
 +++ busybox-1.4.2/Makefile.flags
 @@ -28,4 +28,8 @@
@@ -6,6 +18,6 @@
  endif
 +
 +ifeq ($(CONFIG_SELINUX),y)
-+LDFLAGS += -lselinux -lsepol
++LDLIBS += -lselinux -lsepol
 +endif
  #LDFLAGS += -nostdlib