- version bump to deal with the creation of PT_PAX_FLAGS on upx compressed executable...
authorNed Ludd <solar@gentoo.org>
Mon, 16 Apr 2007 23:10:52 +0000 (23:10 +0000)
committerNed Ludd <solar@gentoo.org>
Mon, 16 Apr 2007 23:10:52 +0000 (23:10 +0000)
Package-Manager: portage-2.1.2_pre1

sys-apps/paxctl/ChangeLog
sys-apps/paxctl/files/digest-paxctl-0.5 [new file with mode: 0644]
sys-apps/paxctl/paxctl-0.4.ebuild
sys-apps/paxctl/paxctl-0.5.ebuild [new file with mode: 0644]

index 18d33afb5bd16775d40457c83467366fbcbbe17d..4ffe63bff9e2538ea34043fb703592108289bc7a 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-apps/paxctl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.22 2006/12/12 14:58:12 jer Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.23 2007/04/16 23:10:52 solar Exp $
+
+*paxctl-0.5 (16 Apr 2007)
+
+  16 Apr 2007; <solar@gentoo.org> -files/paxctl-0.3-error-codes.patch,
+  -paxctl-0.3.ebuild, -paxctl-0.3-r1.ebuild, +paxctl-0.5.ebuild:
+  - version bump to deal with the creation of PT_PAX_FLAGS on upx compressed
+  executables. I removed some older ebuilds also.
 
   12 Dec 2006; Jeroen Roovers <jer@gentoo.org> paxctl-0.4.ebuild:
   Stable for HPPA (bug #157870).
diff --git a/sys-apps/paxctl/files/digest-paxctl-0.5 b/sys-apps/paxctl/files/digest-paxctl-0.5
new file mode 100644 (file)
index 0000000..3ca890a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6ec138522977dc7654d33ddbe32755f0 paxctl-0.5.tar.gz 7587
+RMD160 1abdf467a1b4a30a2ec6f522bcbc607b0a76ff90 paxctl-0.5.tar.gz 7587
+SHA256 d26e33179b31bb9fc3cbe5eb708ec29db4c4eba68600a89ac302856946a0d1d0 paxctl-0.5.tar.gz 7587
index 5b6005b848e292041b51beb3eaf6d272f7354a74..f9c0a8e52307fe2e687a1035b5de54ea37f3cc05 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.4.ebuild,v 1.8 2006/12/12 14:58:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.4.ebuild,v 1.9 2007/04/16 23:10:52 solar Exp $
 
 inherit flag-o-matic
 
diff --git a/sys-apps/paxctl/paxctl-0.5.ebuild b/sys-apps/paxctl/paxctl-0.5.ebuild
new file mode 100644 (file)
index 0000000..6cd2770
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.5.ebuild,v 1.1 2007/04/16 23:10:52 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       einstall DESTDIR="${D}"
+       dodoc README ChangeLog
+}