app-emulation/libvirt: version bump to 4.10.0
authorMatthias Maier <tamiko@gentoo.org>
Wed, 26 Dec 2018 03:03:36 +0000 (21:03 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Wed, 26 Dec 2018 03:27:05 +0000 (21:27 -0600)
 * fix apparmor rules, bug #667434
 * include netcat alternatives, bug #672992

Closes: https://bugs.gentoo.org/667434
Closes: https://bugs.gentoo.org/672992
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/libvirt/Manifest
app-emulation/libvirt/files/libvirt-4.10.0-fix_apparmor_rules.patch [new file with mode: 0644]
app-emulation/libvirt/libvirt-4.10.0.ebuild [new file with mode: 0644]

index 645f72cfa584ea8dfd45aa09e19e8a5c581d30c8..19f7d33e6712dd4c34ffa30fdd2f94db6cda2b1f 100644 (file)
@@ -1,2 +1,3 @@
+DIST libvirt-4.10.0.tar.xz 14841188 BLAKE2B b52f2ed1c4c65930339a6b6fc9e7b034c7661edc0defdd78642f305b97332c33247bfc552efc43aa75a8d360c0d721d1a58a22fa7a016e7cf14ee2219d70a762 SHA512 a4f97aed6299c7954518ab88738ab781cee0755bfd64094a44468f77f99cac5eb2bc74ecd6aec90177317606ebd073292f5b5d0056054d1d94973fa938589fbd
 DIST libvirt-4.5.0.tar.xz 14743956 BLAKE2B 930852765104b1b22744df0ec4f1c74d89bc0fda80852978f7c857943858cc45eed9b74a3d42668f872540be2637f26c4d9d7859594847e58e6fb4cd33350130 SHA512 26710c7e5219f007524e9f93a642e55e4e8ea197afa6b2ca6a4b67b7028313f4b0d82924ee9a1e91ff688a4d2b53f89f3655fbeef0fa99a34f8418f37d787984
 DIST libvirt-4.9.0.tar.xz 14744184 BLAKE2B 03ddefc8f505c8688ad506b81ea9b37ee085e4c9c429834c6b6f338981bfc3c6034a5455a79feca604fb36e658de766ee6104aeed690c682ae596d10eb5632a9 SHA512 3cfada940f9de6cc4b0504e089f41aa03d9986f0163344dd3b3ab8e6c4eb556a56996dc8f24bca913b036862c75b256628ea9ab7674ef0a57b87f47c58689e90
diff --git a/app-emulation/libvirt/files/libvirt-4.10.0-fix_apparmor_rules.patch b/app-emulation/libvirt/files/libvirt-4.10.0-fix_apparmor_rules.patch
new file mode 100644 (file)
index 0000000..e561bf4
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/examples/apparmor/usr.lib.libvirt.virt-aa-helper b/examples/apparmor/usr.lib.libvirt.virt-aa-helper
+index de94368..5fbae27 100644
+--- a/examples/apparmor/usr.lib.libvirt.virt-aa-helper
++++ b/examples/apparmor/usr.lib.libvirt.virt-aa-helper
+@@ -39,6 +39,9 @@ profile virt-aa-helper /usr/{lib,lib64}/libvirt/virt-aa-helper {
+   /etc/apparmor.d/libvirt/* r,
+   /etc/apparmor.d/libvirt/libvirt-[0-9a-f]*-[0-9a-f]*-[0-9a-f]*-[0-9a-f]*-[0-9a-f]* rw,
++  # Gentoo specific path for uefi firmware
++  /usr/share/edk2-ovmf/* r,
++
+   # for backingstore -- allow access to non-hidden files in @{HOME} as well
+   # as storage pools
+   audit deny @{HOME}/.* mrwkl,
diff --git a/app-emulation/libvirt/libvirt-4.10.0.ebuild b/app-emulation/libvirt/libvirt-4.10.0.ebuild
new file mode 100644 (file)
index 0000000..4ee860e
--- /dev/null
@@ -0,0 +1,387 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit autotools bash-completion-r1 eutils linux-info python-any-r1 readme.gentoo-r1 systemd user
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://libvirt.org/git/libvirt.git"
+       SRC_URI=""
+       KEYWORDS=""
+       SLOT="0"
+else
+       # Versions with 4 numbers are stable updates:
+       if [[ ${PV} =~ ^[0-9]+(\.[0-9]+){3} ]]; then
+               SRC_URI="https://libvirt.org/sources/stable_updates/${P}.tar.xz"
+       else
+               SRC_URI="https://libvirt.org/sources/${P}.tar.xz"
+       fi
+       KEYWORDS="~amd64 ~arm64 ~x86"
+       SLOT="0/${PV}"
+fi
+
+DESCRIPTION="C toolkit to manipulate virtual machines"
+HOMEPAGE="http://www.libvirt.org/"
+LICENSE="LGPL-2.1"
+IUSE="
+       apparmor audit +caps +dbus firewalld fuse glusterfs iscsi +libvirtd lvm
+       libssh lxc +macvtap nfs nls numa openvz parted pcap phyp policykit
+       +qemu rbd sasl selinux +udev uml +vepa virtualbox virt-network
+       wireshark-plugins xen zeroconf zfs
+"
+
+REQUIRED_USE="
+       firewalld? ( virt-network )
+       libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
+       lxc? ( caps libvirtd )
+       openvz? ( libvirtd )
+       policykit? ( dbus )
+       qemu? ( libvirtd )
+       uml? ( libvirtd )
+       vepa? ( macvtap )
+       virt-network? ( libvirtd )
+       virtualbox? ( libvirtd )
+       xen? ( libvirtd )"
+
+# gettext.sh command is used by the libvirt command wrappers, and it's
+# non-optional, so put it into RDEPEND.
+# We can use both libnl:1.1 and libnl:3, but if you have both installed, the
+# package will use 3 by default. Since we don't have slot pinning in an API,
+# we must go with the most recent
+RDEPEND="
+       app-misc/scrub
+       dev-libs/libgcrypt:0
+       dev-libs/libnl:3
+       >=dev-libs/libxml2-2.7.6
+       || (
+               >=net-analyzer/gnu-netcat-0.7.1-r3
+               >=net-analyzer/netcat-110-r9
+               >=net-analyzer/netcat6-1.0-r2
+               >=net-analyzer/openbsd-netcat-1.105-r1
+       )
+       >=net-libs/gnutls-1.0.25:0=
+       net-libs/libssh2
+       net-libs/libtirpc
+       net-libs/rpcsvc-proto
+       >=net-misc/curl-7.18.0
+       sys-apps/dmidecode
+       >=sys-apps/util-linux-2.17
+       sys-devel/gettext
+       sys-libs/ncurses:0=
+       sys-libs/readline:=
+       apparmor? ( sys-libs/libapparmor )
+       audit? ( sys-process/audit )
+       caps? ( sys-libs/libcap-ng )
+       dbus? ( sys-apps/dbus )
+       firewalld? ( net-firewall/firewalld )
+       fuse? ( >=sys-fs/fuse-2.8.6:= )
+       glusterfs? ( >=sys-cluster/glusterfs-3.4.1 )
+       iscsi? ( sys-block/open-iscsi )
+       libssh? ( net-libs/libssh )
+       lvm? ( >=sys-fs/lvm2-2.02.48-r2[-device-mapper-only(-)] )
+       nfs? ( net-fs/nfs-utils )
+       numa? (
+               >sys-process/numactl-2.0.2
+               sys-process/numad
+       )
+       parted? (
+               >=sys-block/parted-1.8[device-mapper]
+               sys-fs/lvm2[-device-mapper-only(-)]
+       )
+       pcap? ( >=net-libs/libpcap-1.0.0 )
+       policykit? ( >=sys-auth/polkit-0.9 )
+       qemu? (
+               >=app-emulation/qemu-1.5.0
+               dev-libs/yajl
+       )
+       rbd? ( sys-cluster/ceph )
+       sasl? ( dev-libs/cyrus-sasl )
+       selinux? ( >=sys-libs/libselinux-2.0.85 )
+       virt-network? (
+               net-dns/dnsmasq[script]
+               net-firewall/ebtables
+               >=net-firewall/iptables-1.4.10[ipv6]
+               net-misc/radvd
+               sys-apps/iproute2[-minimal]
+       )
+       virtualbox? ( || ( app-emulation/virtualbox >=app-emulation/virtualbox-bin-2.2.0 ) )
+       wireshark-plugins? ( net-analyzer/wireshark:= )
+       xen? (
+               >=app-emulation/xen-4.6.0
+               app-emulation/xen-tools:=
+       )
+       udev? (
+               virtual/udev
+               >=x11-libs/libpciaccess-0.10.9
+       )
+       zeroconf? ( >=net-dns/avahi-0.6[dbus] )
+       zfs? ( sys-fs/zfs )"
+
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       app-text/xhtml1
+       dev-lang/perl
+       dev-libs/libxslt
+       dev-perl/XML-XPath
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.5.0-do_not_use_sysconf.patch
+       "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
+       "${FILESDIR}"/${PN}-4.10.0-fix_apparmor_rules.patch
+)
+
+pkg_setup() {
+       if use qemu; then
+               enewgroup qemu 77
+               enewuser qemu 77 -1 -1 "qemu,kvm"
+       fi
+
+       use policykit && enewgroup libvirt
+
+       # Check kernel configuration:
+       CONFIG_CHECK=""
+       use fuse && CONFIG_CHECK+="
+               ~FUSE_FS"
+
+       use lvm && CONFIG_CHECK+="
+               ~BLK_DEV_DM
+               ~DM_MULTIPATH
+               ~DM_SNAPSHOT"
+
+       use lxc && CONFIG_CHECK+="
+               ~BLK_CGROUP
+               ~CGROUP_CPUACCT
+               ~CGROUP_DEVICE
+               ~CGROUP_FREEZER
+               ~CGROUP_NET_PRIO
+               ~CGROUP_PERF
+               ~CGROUPS
+               ~CGROUP_SCHED
+               ~CPUSETS
+               ~IPC_NS
+               ~MACVLAN
+               ~NAMESPACES
+               ~NET_CLS_CGROUP
+               ~NET_NS
+               ~PID_NS
+               ~POSIX_MQUEUE
+               ~SECURITYFS
+               ~USER_NS
+               ~UTS_NS
+               ~VETH
+               ~!GRKERNSEC_CHROOT_MOUNT
+               ~!GRKERNSEC_CHROOT_DOUBLE
+               ~!GRKERNSEC_CHROOT_PIVOT
+               ~!GRKERNSEC_CHROOT_CHMOD
+               ~!GRKERNSEC_CHROOT_CAPS"
+
+       kernel_is lt 4 7 && use lxc && CONFIG_CHECK+="
+               ~DEVPTS_MULTIPLE_INSTANCES"
+
+       use macvtap && CONFIG_CHECK+="
+               ~MACVTAP"
+
+       use virt-network && CONFIG_CHECK+="
+               ~BRIDGE_EBT_MARK_T
+               ~BRIDGE_NF_EBTABLES
+               ~NETFILTER_ADVANCED
+               ~NETFILTER_XT_CONNMARK
+               ~NETFILTER_XT_MARK
+               ~NETFILTER_XT_TARGET_CHECKSUM"
+       # Bandwidth Limiting Support
+       use virt-network && CONFIG_CHECK+="
+               ~BRIDGE_EBT_T_NAT
+               ~IP_NF_TARGET_REJECT
+               ~NET_ACT_POLICE
+               ~NET_CLS_FW
+               ~NET_CLS_U32
+               ~NET_SCH_HTB
+               ~NET_SCH_INGRESS
+               ~NET_SCH_SFQ"
+
+       # Handle specific kernel versions for different features
+       kernel_is lt 3 6 && CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+       if kernel_is ge 3 6; then
+               CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP "
+               kernel_is lt 4 5 && CONFIG_CHECK+=" ~MEMCG_KMEM "
+       fi
+
+       ERROR_USER_NS="Optional depending on LXC configuration."
+
+       if [[ -n ${CONFIG_CHECK} ]]; then
+               linux-info_pkg_setup
+       fi
+}
+
+src_prepare() {
+       touch "${S}/.mailmap"
+
+       default
+
+       if [[ ${PV} = *9999* ]]; then
+               # git checkouts require bootstrapping to create the configure script.
+               # Additionally the submodules must be cloned to the right locations
+               # bug #377279
+               ./bootstrap || die "bootstrap failed"
+               (
+                       git submodule status | sed 's/^[ +-]//;s/ .*//'
+                       git hash-object bootstrap.conf
+               ) >.git-module-status
+       fi
+
+       # Tweak the init script:
+       cp "${FILESDIR}/libvirtd.init-r16" "${S}/libvirtd.init" || die
+       sed -e "s/USE_FLAG_FIREWALLD/$(usex firewalld 'need firewalld' '')/" \
+               -e "s/USE_FLAG_AVAHI/$(usex zeroconf 'use avahi-daemon' '')/" \
+               -e "s/USE_FLAG_ISCSI/$(usex iscsi 'use iscsid' '')/" \
+               -e "s/USE_FLAG_RBD/$(usex rbd 'use ceph' '')/" \
+               -i "${S}/libvirtd.init" || die "sed failed"
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_with apparmor)
+               $(use_with apparmor apparmor-profiles)
+               $(use_with audit)
+               $(use_with caps capng)
+               $(use_with dbus)
+               $(use_with firewalld)
+               $(use_with fuse)
+               $(use_with glusterfs)
+               $(use_with glusterfs storage-gluster)
+               $(use_with iscsi storage-iscsi)
+               $(use_with libvirtd)
+               $(use_with libssh)
+               $(use_with lvm storage-lvm)
+               $(use_with lvm storage-mpath)
+               $(use_with lxc)
+               $(use_with macvtap)
+               $(use_enable nls)
+               $(use_with numa numactl)
+               $(use_with numa numad)
+               $(use_with openvz)
+               $(use_with parted storage-disk)
+               $(use_with pcap libpcap)
+               $(use_with phyp)
+               $(use_with policykit polkit)
+               $(use_with qemu)
+               $(use_with qemu yajl)
+               $(use_with rbd storage-rbd)
+               $(use_with sasl)
+               $(use_with selinux)
+               $(use_with udev)
+               $(use_with uml)
+               $(use_with vepa virtualport)
+               $(use_with virt-network network)
+               $(use_with wireshark-plugins wireshark-dissector)
+               $(use_with xen libxl)
+               $(use_with zeroconf avahi)
+               $(use_with zfs storage-zfs)
+
+               --without-hal
+               --without-netcf
+               --without-sanlock
+
+               --with-esx
+               --with-init-script=systemd
+               --with-qemu-group=$(usex caps qemu root)
+               --with-qemu-user=$(usex caps qemu root)
+               --with-remote
+               --with-storage-fs
+               --with-vmware
+
+               --disable-static
+               --disable-werror
+
+               --with-html-subdir=${PF}/html
+               --localstatedir=/var
+       )
+
+       if use virtualbox && has_version app-emulation/virtualbox-ose; then
+               myeconfargs+=( --with-vbox=/usr/lib/virtualbox-ose/ )
+       else
+               myeconfargs+=( $(use_with virtualbox vbox) )
+       fi
+
+       econf "${myeconfargs[@]}"
+
+       if [[ ${PV} = *9999* ]]; then
+               # Restore gnulib's config.sub and config.guess
+               # bug #377279
+               (cd .gnulib && git reset --hard > /dev/null)
+       fi
+}
+
+src_test() {
+       cd "${BUILD_DIR}"
+
+       # remove problematic tests, bug #591416, bug #591418
+       sed -i -e 's#commandtest$(EXEEXT) # #' \
+               -e 's#virfirewalltest$(EXEEXT) # #' \
+               -e 's#nwfilterebiptablestest$(EXEEXT) # #' \
+               -e 's#nwfilterxml2firewalltest$(EXEEXT)$##' \
+               tests/Makefile
+
+       export VIR_TEST_DEBUG=1
+       HOME="${T}" emake check || die "tests failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" \
+               SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" install
+
+       find "${D}" -name '*.la' -delete || die
+
+       # Remove bogus, empty directories. They are either not used, or
+       # libvirtd is able to create them on demand
+       rm -rf "${D}"/etc/sysconfig
+       rm -rf "${D}"/var
+
+       use libvirtd || return 0
+       # From here, only libvirtd-related instructions, be warned!
+
+       systemd_install_serviced \
+               "${FILESDIR}"/libvirtd.service.conf libvirtd.service
+
+       systemd_newtmpfilesd "${FILESDIR}"/libvirtd.tmpfiles.conf libvirtd.conf
+
+       newinitd "${S}/libvirtd.init" libvirtd || die
+       newinitd "${FILESDIR}/libvirt-guests.init-r3" libvirt-guests || die
+       newinitd "${FILESDIR}/virtlockd.init-r1" virtlockd || die
+       newinitd "${FILESDIR}/virtlogd.init-r1" virtlogd || die
+
+       newconfd "${FILESDIR}/libvirtd.confd-r5" libvirtd || die
+       newconfd "${FILESDIR}/libvirt-guests.confd" libvirt-guests || die
+
+       newbashcomp "${S}/tools/bash-completion/vsh" vsh
+       bashcomp_alias vsh virsh virt-admin
+
+       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
+       DISABLE_AUTOFORMATTING=true
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       # we only ever want to generate this once
+       if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
+               rm -rf "${D}"/etc/libvirt/qemu/networks/default.xml
+       fi
+}
+
+pkg_postinst() {
+       if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
+               touch "${ROOT}"/etc/libvirt/qemu/networks/default.xml
+       fi
+
+       use libvirtd || return 0
+       # From here, only libvirtd-related instructions, be warned!
+
+       readme.gentoo_print_elog
+}