dev-python/ntplib: Enable py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 19:40:11 +0000 (21:40 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 20:12:56 +0000 (22:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ntplib/ntplib-0.3.3.ebuild

index 37e5fcbc114c4f4d9858bc924150f25c0810fd23..11967a49ea267df989e64f77d4065e3e4b5cfa0d 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -18,5 +18,5 @@ IUSE=""
 RESTRICT="test"
 
 python_test() {
-       "${PYTHON:-python}" ./test_ntplib.py
+       "${EPYTHON}" ./test_ntplib.py || die
 }