dev-python/cloudpickle: Add missing test-dep on psutil
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 20:28:05 +0000 (22:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 20:40:37 +0000 (22:40 +0200)
Closes: https://bugs.gentoo.org/719650
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cloudpickle/cloudpickle-1.3.0.ebuild

index 96720e650777fb057b522f8addff7c360e96d7f8..332544bb5dc46783d29c325fb5ce57dd45ea1b33 100644 (file)
@@ -12,7 +12,6 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux"
-
 IUSE="test"
 RESTRICT="!test? ( test )"
 
@@ -20,7 +19,9 @@ RDEPEND=""
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}] )"
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/psutil[${PYTHON_USEDEP}]
+       )"
 
 python_test() {
        # -s unbreaks some tests