dev-python/uritemplate-3.0.1-r1: revbump, EAPI=7, py38, enable tests
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 13 May 2020 03:12:13 +0000 (20:12 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 13 May 2020 04:00:31 +0000 (21:00 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild b/dev-python/uritemplate/uritemplate-3.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..250a5e8
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/simplejson[${PYTHON_USEDEP}]
+       !<=dev-python/google-api-python-client-1.3
+"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-python/wheel[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest