media-fonts/office-code-pro: new font package
authorJoonas Niilola <juippis@gentoo.org>
Sun, 23 Feb 2020 06:51:30 +0000 (08:51 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 23 Feb 2020 06:52:12 +0000 (08:52 +0200)
 - Customized version of Source Code Pro.

Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-fonts/office-code-pro/Manifest [new file with mode: 0644]
media-fonts/office-code-pro/metadata.xml [new file with mode: 0644]
media-fonts/office-code-pro/office-code-pro-1.004.ebuild [new file with mode: 0644]

diff --git a/media-fonts/office-code-pro/Manifest b/media-fonts/office-code-pro/Manifest
new file mode 100644 (file)
index 0000000..7de2597
--- /dev/null
@@ -0,0 +1 @@
+DIST office-code-pro-1.004.tar.gz 2910992 BLAKE2B 06d070cfdfa88a1cb62bbf59259c8e783ea9bdfe3903c637c9161b6e476d5cea42fd88625a69a13ae474bc5f31ae40862d7c072b13f100f90955c1ca2c9570d8 SHA512 fc621d281712ef034168b63d853234ab311476d60ff20086f7eba5081292418715e4660e460ce7b6b6f5652d8f52bbd0282dddae419a39f0ba1b9273bbc9f72d
diff --git a/media-fonts/office-code-pro/metadata.xml b/media-fonts/office-code-pro/metadata.xml
new file mode 100644 (file)
index 0000000..6b0a0fb
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>juippis@gentoo.org</email>
+    <name>Joonas Niilola</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/media-fonts/office-code-pro/office-code-pro-1.004.ebuild b/media-fonts/office-code-pro/office-code-pro-1.004.ebuild
new file mode 100644 (file)
index 0000000..23be187
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Customized version of Source Code Pro"
+HOMEPAGE="https://github.com/nathco/Office-Code-Pro"
+SRC_URI="https://github.com/nathco/Office-Code-Pro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/Office-Code-Pro-${PV}"
+
+FONT_S="${S}"
+FONT_SUFFIX="otf"
+
+src_prepare() {
+       default
+
+       mv Fonts/*/OTF/*.otf . || die "Failed to move .otf files"
+}