media-libs/zxing-cpp: Fix pkgconfig version
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 9 Apr 2020 17:17:15 +0000 (19:17 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 9 Apr 2020 21:36:22 +0000 (23:36 +0200)
Thanks-to: cyrillic <cyrilmaley@hotmail.com>
Closes: https://bugs.gentoo.org/716818
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/zxing-cpp/files/zxing-cpp-1.0.8-pkgconfig.patch [new file with mode: 0644]
media-libs/zxing-cpp/zxing-cpp-1.0.8-r1.ebuild [new file with mode: 0644]

diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.0.8-pkgconfig.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.0.8-pkgconfig.patch
new file mode 100644 (file)
index 0000000..d1dda4f
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/zxing.pc.in      2020-04-09 11:43:22.494219440 -0400
++++ b/zxing.pc.in      2020-04-09 11:49:03.884867034 -0400
+@@ -5,6 +5,6 @@
+ Name: ZXing
+ Description: ZXing library set
+-Version: @VERSION@
++Version: @PROJECT_VERSION@
+ Libs: -L${libdir} -l@TARGET_ZXING@ 
+ Cflags: -I${includedir} -I${includedir}/ZXing
\ No newline at end of file
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.0.8-r1.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.0.8-r1.ebuild
new file mode 100644 (file)
index 0000000..4d6ad24
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ Multi-format 1D/2D barcode image processing library"
+HOMEPAGE="https://github.com/nu-book/zxing-cpp"
+SRC_URI="https://github.com/nu-book/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-pkgconfig.patch" ) # bug 716818