dev-util/ccls: Add new package
authorMatt Turner <mattst88@gentoo.org>
Tue, 4 Feb 2020 19:32:20 +0000 (11:32 -0800)
committerMatt Turner <mattst88@gentoo.org>
Wed, 5 Feb 2020 06:56:26 +0000 (22:56 -0800)
Closes: https://bugs.gentoo.org/691060
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/ccls/Manifest [new file with mode: 0644]
dev-util/ccls/ccls-0.20190823.5.ebuild [new file with mode: 0644]
dev-util/ccls/ccls-9999.ebuild [new file with mode: 0644]
dev-util/ccls/metadata.xml [new file with mode: 0644]

diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
new file mode 100644 (file)
index 0000000..84534b3
--- /dev/null
@@ -0,0 +1 @@
+DIST ccls-0.20190823.5.tar.gz 158118 BLAKE2B 09b4a985a284fe74adc408eb9e86094aaf4ebfaf50de3238a17299efabe4749326b8239356c2808ca500a44bef664b2a654e9b16c83c3ef04cd7cf90c56fe3ef SHA512 3c4ecac663eb463870153734fa6206701ede9d72bae3b6eae9c26adab2979ad79d2ac860c1ffb07f8cfcea4aa63afed90510734d91f830c99a86b3811959583f
diff --git a/dev-util/ccls/ccls-0.20190823.5.ebuild b/dev-util/ccls/ccls-0.20190823.5.ebuild
new file mode 100644 (file)
index 0000000..d959663
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       dev-libs/rapidjson
+       sys-devel/clang:=
+       sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       local mycmakeargs=(
+               -DUSE_SYSTEM_RAPIDJSON=ON
+       )
+       cmake_src_configure
+}
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
new file mode 100644 (file)
index 0000000..d959663
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       dev-libs/rapidjson
+       sys-devel/clang:=
+       sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       local mycmakeargs=(
+               -DUSE_SYSTEM_RAPIDJSON=ON
+       )
+       cmake_src_configure
+}
diff --git a/dev-util/ccls/metadata.xml b/dev-util/ccls/metadata.xml
new file mode 100644 (file)
index 0000000..73e87fe
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mattst88@gentoo.org</email>
+               <name>Matt Turner</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">MaskRay/ccls</remote-id>
+       </upstream>
+</pkgmetadata>