app-editors/emacs-vcs: Call autogen.sh unconditionally.
authorUlrich Müller <ulm@gentoo.org>
Wed, 15 Mar 2017 08:15:15 +0000 (09:15 +0100)
committerUlrich Müller <ulm@gentoo.org>
Wed, 15 Mar 2017 08:15:15 +0000 (09:15 +0100)
It will not only be needed for live versions, but for snapshots too.
Add explicit ./autogen.sh path.

Package-Manager: Portage-2.3.4, Repoman-2.3.2

app-editors/emacs-vcs/emacs-vcs-26.0.9999.ebuild

index ef85072615b7b5df5e4081a9d50f0dd85f0742f6..efb82a521ffe24b5f1a09cf7cbab65c7b88e82c7 100644 (file)
@@ -112,9 +112,6 @@ src_prepare() {
                einfo "Emacs version number: ${FULL_VERSION}"
                [[ ${FULL_VERSION} =~ ^${PV%.*}(\..*)?$ ]] \
                        || die "Upstream version number changed to ${FULL_VERSION}"
-
-               #605400
-               bash -c 'autoreconf() { :; }; . $0 "$@"' autogen.sh --no-check || die
        fi
 
        eapply_user
@@ -123,6 +120,8 @@ src_prepare() {
        sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" doc/man/ctags.1 \
                || die "unable to sed ctags.1"
 
+       bash -c 'autoreconf() { echo nope; }; . $0 "$@"' \
+               ./autogen.sh --no-check || die  #605400
        AT_M4DIR=m4 eautoreconf
        touch src/stamp-h.in || die
 }