dev-ml/ocamlbuild: add missing findlib test dep, bug #624150
authorAlexis Ballier <aballier@gentoo.org>
Fri, 7 Jul 2017 17:45:11 +0000 (19:45 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 7 Jul 2017 17:45:23 +0000 (19:45 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ml/ocamlbuild/ocamlbuild-0.11.0.ebuild

index 8b0e155ea7c01a93a0535c25d4b73ebf6c9f0922..36621246391ccd322111827c715e38c2d7149043 100644 (file)
@@ -10,12 +10,14 @@ SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz
 LICENSE="LGPL-2.1-with-linking-exception"
 SLOT="0/${PV}"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
 
 DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
 RDEPEND="${DEPEND}
        !<dev-ml/findlib-1.6.1-r1
 "
+DEPEND="${DEPEND}
+       test? ( dev-ml/findlib )"
 
 src_configure() {
        emake -f configure.make Makefile.config \