dev-php/PEAR-Structures_Graph: Version bump
authorBrian Evans <grknight@gentoo.org>
Sun, 16 Aug 2015 02:30:03 +0000 (22:30 -0400)
committerBrian Evans <grknight@gentoo.org>
Sun, 16 Aug 2015 02:30:03 +0000 (22:30 -0400)
Package-Manager: portage-2.2.20.1

dev-php/PEAR-Structures_Graph/Manifest
dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild [new file with mode: 0644]

index e7a4685efb04df99658cf68578481a4f53561383..27ec9e5a159fff7dbc6bf0f67649814e5181f0ce 100644 (file)
@@ -1 +1,2 @@
 DIST Structures_Graph-1.0.4.tgz 30318 SHA256 3619ac17892855117283e3555b1a156df0eb4d175e70e63d9c6d27d2c31a2e4f SHA512 40d45c932c571e38807fbfdcf1df6d4fcab29ab43f518ed313bac2bd35a55396aa2b87790dc827bd2e9e5c5f721df55eadfe83ff1a106bf325c467e44556c9fe WHIRLPOOL af2df6bc3d23eae990fa9c258c6277ee35fec8c9efb3e737f84278e5a3ba1d41202c66f8ae69cfc8054fb5f6b544b6407300cf25fe5ba32f4c3975c44f160c91
+DIST Structures_Graph-1.1.1.tgz 12402 SHA256 00f18a59e517db8c4eb167ada9f2a8a007c5a14b2adafc0308e5c3fad3ddd8de SHA512 cd4feb265e1aa05de348645dfc0b8e336486cb02c553dd8fcacb0a1eab452bf54108e07864395d55e0c92f4ffd338a5ae846b2dc28804bb23f03c91864ef0284 WHIRLPOOL f832c8be32e18c05ccc6958633c423570ece02cae83b4ce2b9f03ecc3d8ef98795f5e951652b3ffc95756f145435449970c568f550ceb265736a55df60fca568
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..facc50b
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# BIG FAT WARNING!
+# Do not use any pear eclass here since pear itself depends on this package.
+# Using the pear eclass will thus create a circular dependency
+
+EAPI="5"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND=">=dev-lang/php-5.3:*[pcre(+)]
+               >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       insinto /usr/share/php
+       doins -r Structures
+# Currently empty except for a sudo-html file
+#      dohtml -r docs/html/*
+}