dev-python/hypothesis: Bump to 5.5.2
authorMichał Górny <mgorny@gentoo.org>
Fri, 14 Feb 2020 05:40:17 +0000 (06:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 14 Feb 2020 07:50:55 +0000 (08:50 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-5.5.2.ebuild [new file with mode: 0644]

index 22065db5d5d26cbb09f2696ade92c67c521f76cf..4b67de73373fe6bb33d7e73c5a4ae34fbca9ce60 100644 (file)
@@ -4,3 +4,4 @@ DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a1
 DIST hypothesis-python-5.4.1.tar.gz 8993002 BLAKE2B b96f9080f7a5b307698ee1119495cb5356ccd2836f1d3ae66077bc0be2793d5d62beba09b2a38e5486f6d0d09e95ac85e81511c5ab7434c7285608a0ae62caa7 SHA512 bf01c50ea998aee2a547132806845aa9330a3830ce2b864f0ab9e2d9b9dd7dbdc9ec4db2ef77bfb9a76467b00f3ca1c00acbba7bdea569dab3038914a598d0c0
 DIST hypothesis-python-5.5.0.tar.gz 8996266 BLAKE2B c9eebe4bf1df5cbf7a40dabeecc9991e71ceda4c2084a1b045f77a2455d5581d055e55b22dde48d627eb3cd3b111bdb06b14ada2f31dccd201390430a4a38c15 SHA512 302211f91be253e15bb84c81e80e72c6de41c3a640569363aeac27b2650e569275f9614a678beb9e03f1e97090de4eab7954bc39b55a4324be0ef0b45daf5228
 DIST hypothesis-python-5.5.1.tar.gz 8996186 BLAKE2B 0e1e013b0339e504603b583882f6d05efa96e5b97b02967c49001c329923df7b2b2666a5351f223ab991cc86f6b0b7ae91c3f6e34c1e089a9f06a271dc7b887f SHA512 4129d85a0e4d2614cd2d8d018043b6346d59f973cce79cdbab2d8688d1c18e9dd0b9044515d715c80e03812020f134a8897931a9942eaad181567750a7cee049
+DIST hypothesis-python-5.5.2.tar.gz 8996253 BLAKE2B eccdbae595e3242b6e0f8d5b363aa4b23f279959bf87e801885be2f072ea8cafa39ec1122695f26a333ee99a191cf17342d95b74a4d216e06fecda53ab47d96f SHA512 e2be0bfd07e0e192e104b827616f822c1a4e87f7691a6b754a623d8ec268851f769ff9a0bf64c424cf583b5d87e4040df92ec203eac1b41034b4d24d5ea1d1d2
diff --git a/dev-python/hypothesis/hypothesis-5.5.2.ebuild b/dev-python/hypothesis/hypothesis-5.5.2.ebuild
new file mode 100644 (file)
index 0000000..d1f7fce
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pexpect[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+               !!<dev-python/typing-3.7.4.1
+       )
+"
+
+src_prepare() {
+       # avoid pytest-xdist dep for one test
+       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+               tests/pytest/test_statistics.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       pytest -vv tests/cover tests/pytest tests/quality ||
+               die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "dateutil support" dev-python/python-dateutil
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pandas support" dev-python/pandas
+       optfeature "pytest support" dev-python/pytest
+}