app-metrics/bind_exporter: 0.3.0 bump
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 2 May 2020 23:14:11 +0000 (18:14 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 2 May 2020 23:18:22 +0000 (18:18 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-metrics/bind_exporter/Manifest
app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild [new file with mode: 0644]

index 89407b193389175dd6d5048169aff49160968c02..11a260628b3ca8cefb575ed9e0c6c0fd5c32f3cf 100644 (file)
@@ -1 +1,2 @@
 DIST bind_exporter-0.2.0_p20190226.tar.gz 874497 BLAKE2B ce04a168be6844d43ed2c358aa6469d5dbae1730825e4c3c038805f4bbf071bfae2936a6a5341832939e3ed249e5d484f2ca0908ac0e717cd2b5ced496c44a49 SHA512 95a8ae6f7c6470345d5a5f7e4e36eae282e5ca74393dd4372342f44732b54a6cc977ae037d6d16ae4ce6a9ac526b2e01721f5468a6469c30ae60ca59dfec8d5a
+DIST bind_exporter-0.3.0.tar.gz 1796507 BLAKE2B a79b9e0d159d3deb83f1a040325ad34bc0d4ae50b6af205dce4ebf8d7152ccbd4b7d46fda40bf76db953996ddf4237ca13058250478b08cca51b8bea08ccc31b SHA512 762901a63a9493f852e5514429f55b10400931f0a77d2e11c7565e93e1ff759eb30d3bbc9278451bb9df358a983aa099bd55cf57241cf36187d2789c89a3852d
diff --git a/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild b/app-metrics/bind_exporter/bind_exporter-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..bd00e47
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+GIT_COMMIT=c34ff3d6b4817f42e74b2b05b3797cf99683b4a9
+
+DESCRIPTION="Prometheus exporter for BIND"
+HOMEPAGE="https://github.com/digitalocean/bind_exporter"
+SRC_URI="https://github.com/digitalocean/bind_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="acct-group/bind_exporter
+       acct-user/bind_exporter"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-util/promu"
+
+src_prepare() {
+       default
+       sed -i -e "/-s$/d" -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
+}
+
+src_compile() {
+       mkdir -p bin || die
+       promu build -v --prefix bin || die
+}
+
+src_install() {
+       dobin bin/${PN}
+       dodoc {README,CHANGELOG}.md
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+       keepdir /var/log/${PN}
+       fowners ${PN}:${PN} /var/log/${PN}
+}
+
+pkg_postinst() {
+       elog "Make sure BIND was built with libxml2 support. You can check with the"
+       elog "following command: named -V | grep libxml2."
+       elog "Configure BIND to open a statistics channel. It's recommended to run"
+       elog "the bind_exporter next to BIND, so it's only necessary to open a port"
+       elog "locally."
+       elog ""
+       elog "statistics-channels {"
+       elog "inet 127.0.0.1 port 8053 allow { 127.0.0.1; };"
+       elog "};"
+}