alpha/ia64 love for autotrace
authorMike Frysinger <vapier@gentoo.org>
Sat, 20 Jan 2007 14:21:20 +0000 (14:21 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 20 Jan 2007 14:21:20 +0000 (14:21 +0000)
Package-Manager: portage-2.1.2

media-gfx/pstoedit/pstoedit-3.42.ebuild

index 5922caaa719b1983532e432e46ad0d22e660348f..0a8358bb5f97ded6c068f9b2e47bdd4084ae28a5 100644 (file)
@@ -1,21 +1,20 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.42.ebuild,v 1.5 2006/07/07 10:03:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.42.ebuild,v 1.6 2007/01/20 14:21:20 vapier Exp $
 
 inherit libtool eutils
 
-# see bug #29724. please don't re-enable flash support until
-# ming has the patches applied <obz@gentoo.org>
-# IUSE="flash emf"
-IUSE="plotutils emf"
-
 DESCRIPTION="translates PostScript and PDF graphics into other vector formats"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 HOMEPAGE="http://www.pstoedit.net/pstoedit"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 
-SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# see bug #29724. please don't re-enable flash support until
+# ming has the patches applied <obz@gentoo.org>
+# IUSE="flash emf"
+IUSE="plotutils emf"
 
 DEPEND="sys-libs/zlib
        !amd64? ( emf? ( media-libs/libemf ) )
@@ -23,20 +22,19 @@ DEPEND="sys-libs/zlib
        media-libs/libexif
        plotutils? ( media-libs/plotutils )"
 #      flash? ( media-libs/ming )"
-
 RDEPEND="${DEPEND}
        virtual/ghostscript"
 
 src_unpack() {
-
-       unpack ${A}; cd ${S}
+       unpack ${A}
+       cd "${S}"
        # need to remove the pedantic flag, see bug #39557
        sed -i -e "s/\-pedantic//" configure
-       epatch ${FILESDIR}/${PN}-m4-quoting.patch
+       epatch "${FILESDIR}"/${PN}-m4-quoting.patch
+       elibtoolize
 }
 
 src_compile() {
-
        local myconf=""
        if ! use amd64 && use emf ; then
                myconf="${myconf} $(use_with emf)"
@@ -45,17 +43,13 @@ src_compile() {
                && myconf="${myconf} --with-libemf-include=/usr/include/libEMF"
        fi
 
-       elibtoolize
        econf ${myconf} $(use_with plotutils libplot) || die "econf failed"
        make || die
-
 }
 
-src_install () {
-
-       make DESTDIR=${D} install || die "make install failed"
-       dodoc readme.txt copying
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+       dodoc readme.txt
        dohtml changelog.htm index.htm doc/pstoedit.htm
        doman doc/pstoedit.1
-
 }