dev-util/valgrind: remove older versions
authorAnthony G. Basile <blueness@gentoo.org>
Thu, 28 May 2020 21:01:58 +0000 (17:01 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Thu, 28 May 2020 21:49:34 +0000 (17:49 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
dev-util/valgrind/Manifest
dev-util/valgrind/valgrind-3.12.0.ebuild [deleted file]
dev-util/valgrind/valgrind-3.13.0-r1.ebuild [deleted file]
dev-util/valgrind/valgrind-3.13.0-r2.ebuild [deleted file]
dev-util/valgrind/valgrind-3.13.0-r3.ebuild [deleted file]
dev-util/valgrind/valgrind-3.13.0.ebuild [deleted file]

index 5d28ed6ed108ad324728e73377035d709cb2b59f..dcf5af4b3c0f857aeebe369771f21453cb1f3591 100644 (file)
@@ -1,4 +1,2 @@
-DIST valgrind-3.12.0.tar.bz2 12788556 BLAKE2B aeebf9c29afb3cce683c6448a3dec8f4edb1e44b2043a8e159c57a28c75fee49c5dba144d7ae2d79d23fe5a6c5b2bbf01fc398909bf12eebc027f8a7d4d83009 SHA512 2c083f7c2e74dc58600397726d9d3af7a2cea40fe3d8733149886d1d77867e6c09996e5be1c58dd932f3662acf7363e04eeadbc0f9c8f0dac089e605024229be
-DIST valgrind-3.13.0.tar.bz2 14723076 BLAKE2B cdf92087575cc851d316e2136081441f528596048bc5d1e9c17539283085dd9accd0c1b3136f9768a62de27d1f1641b450305681a33d9ba9fdfe028a73c0cb99 SHA512 34e1013cd3815d30a459b86220e871bb0a6209cc9e87af968f347083693779f022e986f211bdf1a5184ad7370cde12ff2cfca8099967ff94732970bd04a97009
 DIST valgrind-3.14.0.tar.bz2 16602858 BLAKE2B 00d601593388180cc874cf2f0c78e79f705f145e45ea82996117cb91ba881e7888ef241fb7e45927f82f99666d76ed35cb5d451e9a3ef123c04a0dff233b2269 SHA512 68e548c42df31dc2b883a403e0faff7480c49b3054841870f5d2f742141ba199eca5d83c96bbf283115f0633f2bdb0860161d422f98e3ec720ec65760d250f97
 DIST valgrind-3.15.0.tar.bz2 20241437 BLAKE2B a1bd46d46b3cd9f963773d011e7c74bf5e09e59be13afe38229a3c66a89eeb416498faed67d6ec21489b630b55ac73cc212e17ba515884f8b6374849a60e3720 SHA512 5695d1355226fb63b0c80809ed43bb077b6eed4d427792d9d7ed944c38b557a84fe3c783517b921e32f161228e10e4625bea0550faa4685872bb4454450cfa7f
diff --git a/dev-util/valgrind/valgrind-3.12.0.ebuild b/dev-util/valgrind/valgrind-3.12.0.ebuild
deleted file mode 100644 (file)
index a759d9c..0000000
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="mpi"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # Correct hard coded doc location
-       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
-       # Don't force multiarch stuff on OSX, bug #306467
-       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
-       # Respect CFLAGS, LDFLAGS
-       epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
-       # Changing Makefile.all.am to disable SSP
-       epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
-
-       # Allow users to test their own patches
-       epatch_user
-
-       # Regenerate autotools files
-       eautoreconf
-}
-
-src_configure() {
-       local myconf
-
-       # Respect ar, bug #468114
-       tc-export AR
-
-       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
-       #                       while compiling insn_sse.c in none/tests/x86
-       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
-       #                       because valgrind doesn't link to glibc (bug #114347)
-       # -m64 -mx32                    for multilib-portage, bug #398825
-       # -ggdb3                segmentation fault on startup
-       filter-flags -fomit-frame-pointer
-       filter-flags -fstack-protector
-       filter-flags -m64 -mx32
-       replace-flags -ggdb3 -ggdb2
-
-       if use amd64 || use ppc64; then
-               ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
-       fi
-
-       # Force bitness on darwin, bug #306467
-       use x86-macos && myconf="${myconf} --enable-only32bit"
-       use x64-macos && myconf="${myconf} --enable-only64bit"
-
-       # Don't use mpicc unless the user asked for it (bug #258832)
-       if ! use mpi; then
-               myconf="${myconf} --without-mpicc"
-       fi
-
-       econf ${myconf}
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc AUTHORS FAQ.txt NEWS README*
-
-       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_names on shared libraries, can't turn them into bundles,
-               # as dyld won't load them any more then, bug #306467
-               local l
-               for l in "${ED}"/usr/lib/valgrind/*.so ; do
-                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
-               done
-       fi
-}
-
-pkg_postinst() {
-       elog "Valgrind will not work if glibc does not have debug symbols."
-       elog "To fix this you can add splitdebug to FEATURES in make.conf"
-       elog "and remerge glibc.  See:"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}
diff --git a/dev-util/valgrind/valgrind-3.13.0-r1.ebuild b/dev-util/valgrind/valgrind-3.13.0-r1.ebuild
deleted file mode 100644 (file)
index 5e5e2d8..0000000
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="mpi"
-
-if [[ ${PV} == "9999" ]]; then
-       EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
-       KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-fi
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # Correct hard coded doc location
-       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
-       # Don't force multiarch stuff on OSX, bug #306467
-       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
-       # Respect CFLAGS, LDFLAGS
-       eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
-       # Fix test failures on glibc-2.26
-       eapply "${FILESDIR}"/${P}-test-fixes.patch
-
-       # Allow users to test their own patches
-       eapply_user
-
-       # Regenerate autotools files
-       eautoreconf
-}
-
-src_configure() {
-       local myconf
-
-       # Respect ar, bug #468114
-       tc-export AR
-
-       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
-       #                       while compiling insn_sse.c in none/tests/x86
-       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
-       #                       because valgrind doesn't link to glibc (bug #114347)
-       # -fstack-protector-all    Fails same way as -fstack-protector/-fstack-protector-strong.
-       #                          Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
-       # -fstack-protector-strong See -fstack-protector (bug #620402)
-       # -m64 -mx32                    for multilib-portage, bug #398825
-       # -ggdb3                segmentation fault on startup
-       filter-flags -fomit-frame-pointer
-       filter-flags -fstack-protector
-       filter-flags -fstack-protector-all
-       filter-flags -fstack-protector-strong
-       filter-flags -m64 -mx32
-       replace-flags -ggdb3 -ggdb2
-
-       if use amd64 || use ppc64; then
-               ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
-       fi
-
-       # Force bitness on darwin, bug #306467
-       use x86-macos && myconf="${myconf} --enable-only32bit"
-       use x64-macos && myconf="${myconf} --enable-only64bit"
-
-       # Don't use mpicc unless the user asked for it (bug #258832)
-       if ! use mpi; then
-               myconf="${myconf} --without-mpicc"
-       fi
-
-       econf ${myconf}
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       if [[ ${PV} == "9999" ]]; then
-               # Otherwise FAQ.txt won't exist:
-               emake -C docs FAQ.txt
-               mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
-       fi
-
-       dodoc AUTHORS FAQ.txt NEWS README*
-
-       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_names on shared libraries, can't turn them into bundles,
-               # as dyld won't load them any more then, bug #306467
-               local l
-               for l in "${ED}"/usr/lib/valgrind/*.so ; do
-                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
-               done
-       fi
-}
-
-pkg_postinst() {
-       elog "Valgrind will not work if glibc does not have debug symbols."
-       elog "To fix this you can add splitdebug to FEATURES in make.conf"
-       elog "and remerge glibc.  See:"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}
diff --git a/dev-util/valgrind/valgrind-3.13.0-r2.ebuild b/dev-util/valgrind/valgrind-3.13.0-r2.ebuild
deleted file mode 100644 (file)
index a43faba..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="mpi"
-
-if [[ ${PV} == "9999" ]]; then
-       EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
-       KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-fi
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # Correct hard coded doc location
-       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
-       # Don't force multiarch stuff on OSX, bug #306467
-       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
-       # Respect CFLAGS, LDFLAGS
-       eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
-       # Fix test failures on glibc-2.26
-       eapply "${FILESDIR}"/${P}-test-fixes.patch
-
-       # Fix --xml-socket command line option (qt-creator), bug #641790
-       eapply "${FILESDIR}"/${P}-xml-socket.patch
-
-       if [[ ${CHOST} == *-solaris* ]] ; then
-               # upstream doesn't support this, but we don't build with
-               # Sun/Oracle ld, we have a GNU toolchain, so get some things
-               # working the Linux/GNU way
-               find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
-                       sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
-               cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
-       fi
-
-       # Allow users to test their own patches
-       eapply_user
-
-       # Regenerate autotools files
-       eautoreconf
-}
-
-src_configure() {
-       local myconf=()
-
-       # Respect ar, bug #468114
-       tc-export AR
-
-       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
-       #                       while compiling insn_sse.c in none/tests/x86
-       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
-       #                       because valgrind doesn't link to glibc (bug #114347)
-       # -fstack-protector-all    Fails same way as -fstack-protector/-fstack-protector-strong.
-       #                          Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
-       # -fstack-protector-strong See -fstack-protector (bug #620402)
-       # -m64 -mx32                    for multilib-portage, bug #398825
-       # -ggdb3                segmentation fault on startup
-       filter-flags -fomit-frame-pointer
-       filter-flags -fstack-protector
-       filter-flags -fstack-protector-all
-       filter-flags -fstack-protector-strong
-       filter-flags -m64 -mx32
-       replace-flags -ggdb3 -ggdb2
-
-       if use amd64 || use ppc64; then
-               ! has_multilib_profile && myconf+=("--enable-only64bit")
-       fi
-
-       # Force bitness on darwin, bug #306467
-       use x86-macos && myconf+=("--enable-only32bit")
-       use x64-macos && myconf+=("--enable-only64bit")
-
-       # Don't use mpicc unless the user asked for it (bug #258832)
-       if ! use mpi; then
-               myconf+=("--without-mpicc")
-       fi
-
-       econf "${myconf[@]}"
-}
-
-src_install() {
-       default
-
-       if [[ ${PV} == "9999" ]]; then
-               # Otherwise FAQ.txt won't exist:
-               emake -C docs FAQ.txt
-               mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
-       fi
-
-       dodoc FAQ.txt
-
-       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_names on shared libraries, can't turn them into bundles,
-               # as dyld won't load them any more then, bug #306467
-               local l
-               for l in "${ED}"/usr/lib/valgrind/*.so ; do
-                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
-               done
-       fi
-}
-
-pkg_postinst() {
-       elog "Valgrind will not work if glibc does not have debug symbols."
-       elog "To fix this you can add splitdebug to FEATURES in make.conf"
-       elog "and remerge glibc.  See:"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}
diff --git a/dev-util/valgrind/valgrind-3.13.0-r3.ebuild b/dev-util/valgrind/valgrind-3.13.0-r3.ebuild
deleted file mode 100644 (file)
index 287d09b..0000000
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="mpi"
-
-if [[ ${PV} == "9999" ]]; then
-       EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
-       KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-fi
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # Correct hard coded doc location
-       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
-       # Don't force multiarch stuff on OSX, bug #306467
-       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
-       # Respect CFLAGS, LDFLAGS
-       eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
-       # Fix test failures on glibc-2.26
-       eapply "${FILESDIR}"/${P}-test-fixes.patch
-
-       # Fix --xml-socket command line option (qt-creator), bug #641790
-       eapply "${FILESDIR}"/${P}-xml-socket.patch
-
-       # Fix reading debug info from binaries built with -z separate-code, bug #664882
-       eapply "${FILESDIR}"/${P}-accept-read-only-PT_LOAD-segments-and-rodata.patch
-       eapply "${FILESDIR}"/${P}-ignore-further-mappings-after-read-all-debuginfo.patch
-
-       if [[ ${CHOST} == *-solaris* ]] ; then
-               # upstream doesn't support this, but we don't build with
-               # Sun/Oracle ld, we have a GNU toolchain, so get some things
-               # working the Linux/GNU way
-               find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
-                       sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
-               cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
-       fi
-
-       # Allow users to test their own patches
-       eapply_user
-
-       # Regenerate autotools files
-       eautoreconf
-}
-
-src_configure() {
-       local myconf=()
-
-       # Respect ar, bug #468114
-       tc-export AR
-
-       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
-       #                       while compiling insn_sse.c in none/tests/x86
-       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
-       #                       because valgrind doesn't link to glibc (bug #114347)
-       # -fstack-protector-all    Fails same way as -fstack-protector/-fstack-protector-strong.
-       #                          Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
-       # -fstack-protector-strong See -fstack-protector (bug #620402)
-       # -m64 -mx32                    for multilib-portage, bug #398825
-       # -ggdb3                segmentation fault on startup
-       filter-flags -fomit-frame-pointer
-       filter-flags -fstack-protector
-       filter-flags -fstack-protector-all
-       filter-flags -fstack-protector-strong
-       filter-flags -m64 -mx32
-       replace-flags -ggdb3 -ggdb2
-
-       if use amd64 || use ppc64; then
-               ! has_multilib_profile && myconf+=("--enable-only64bit")
-       fi
-
-       # Force bitness on darwin, bug #306467
-       use x86-macos && myconf+=("--enable-only32bit")
-       use x64-macos && myconf+=("--enable-only64bit")
-
-       # Don't use mpicc unless the user asked for it (bug #258832)
-       if ! use mpi; then
-               myconf+=("--without-mpicc")
-       fi
-
-       econf "${myconf[@]}"
-}
-
-src_install() {
-       default
-
-       if [[ ${PV} == "9999" ]]; then
-               # Otherwise FAQ.txt won't exist:
-               emake -C docs FAQ.txt
-               mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
-       fi
-
-       dodoc FAQ.txt
-
-       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_names on shared libraries, can't turn them into bundles,
-               # as dyld won't load them any more then, bug #306467
-               local l
-               for l in "${ED}"/usr/lib/valgrind/*.so ; do
-                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
-               done
-       fi
-}
-
-pkg_postinst() {
-       elog "Valgrind will not work if glibc does not have debug symbols."
-       elog "To fix this you can add splitdebug to FEATURES in make.conf"
-       elog "and remerge glibc.  See:"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}
diff --git a/dev-util/valgrind/valgrind-3.13.0.ebuild b/dev-util/valgrind/valgrind-3.13.0.ebuild
deleted file mode 100644 (file)
index 14799cb..0000000
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
-
-DESCRIPTION="An open-source memory debugger for GNU/Linux"
-HOMEPAGE="http://www.valgrind.org"
-SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="mpi"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # Correct hard coded doc location
-       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
-
-       # Don't force multiarch stuff on OSX, bug #306467
-       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
-
-       # Respect CFLAGS, LDFLAGS
-       eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
-
-       # Changing Makefile.all.am to disable SSP
-       eapply "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
-
-       # Allow users to test their own patches
-       eapply_user
-
-       # Regenerate autotools files
-       eautoreconf
-}
-
-src_configure() {
-       local myconf
-
-       # Respect ar, bug #468114
-       tc-export AR
-
-       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
-       #                       while compiling insn_sse.c in none/tests/x86
-       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
-       #                       because valgrind doesn't link to glibc (bug #114347)
-       # -m64 -mx32                    for multilib-portage, bug #398825
-       # -ggdb3                segmentation fault on startup
-       filter-flags -fomit-frame-pointer
-       filter-flags -fstack-protector
-       filter-flags -m64 -mx32
-       replace-flags -ggdb3 -ggdb2
-
-       if use amd64 || use ppc64; then
-               ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
-       fi
-
-       # Force bitness on darwin, bug #306467
-       use x86-macos && myconf="${myconf} --enable-only32bit"
-       use x64-macos && myconf="${myconf} --enable-only64bit"
-
-       # Don't use mpicc unless the user asked for it (bug #258832)
-       if ! use mpi; then
-               myconf="${myconf} --without-mpicc"
-       fi
-
-       econf ${myconf}
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc AUTHORS FAQ.txt NEWS README*
-
-       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
-
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # fix install_names on shared libraries, can't turn them into bundles,
-               # as dyld won't load them any more then, bug #306467
-               local l
-               for l in "${ED}"/usr/lib/valgrind/*.so ; do
-                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
-               done
-       fi
-}
-
-pkg_postinst() {
-       elog "Valgrind will not work if glibc does not have debug symbols."
-       elog "To fix this you can add splitdebug to FEATURES in make.conf"
-       elog "and remerge glibc.  See:"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
-       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
-}