dev-python/testpath: Build from pyproject.toml
authorMichał Górny <mgorny@gentoo.org>
Sun, 22 Dec 2019 12:43:00 +0000 (13:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 20 Feb 2020 09:35:42 +0000 (10:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/testpath/testpath-0.4.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/testpath/testpath-0.4.4-r1.ebuild b/dev-python/testpath/testpath-0.4.4-r1.ebuild
new file mode 100644 (file)
index 0000000..96724c8
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       test? (
+               dev-python/pathlib2[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc