dev-python/s3transfer: add python3_7
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 17 Sep 2018 12:57:38 +0000 (13:57 +0100)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Wed, 19 Sep 2018 00:03:47 +0000 (01:03 +0100)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-python/s3transfer/s3transfer-0.1.13-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/s3transfer/s3transfer-0.1.13-r1.ebuild b/dev-python/s3transfer/s3transfer-0.1.13-r1.ebuild
new file mode 100644 (file)
index 0000000..37879fd
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="https://github.com/boto/s3transfer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+       dev-python/botocore[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
+"
+# Pin mock to 1.3.0 if testing failures due to mock occur.
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${CDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+       nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
+}