dev-python/botocore: add live ebuild logic
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 25 Dec 2017 15:56:53 +0000 (15:56 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Tue, 26 Dec 2017 02:04:48 +0000 (02:04 +0000)
botocore is released very often - 1.8.0 to 1.8.20 in one month. So it
makes sense to allow users to opt in to being up to date, free from
ebuild bumps delay. Git master branch is always at latest release, so
should be reasonably safe to use.

Package-Manager: Portage-2.3.17, Repoman-2.3.6

dev-python/botocore/botocore-1.8.20.ebuild

index 9e2b1a14bd8e56a40e89cd6981c6b1827b2d7a75..7f976cb95e55cf554ba4214d722f522be7984aec 100644 (file)
@@ -8,13 +8,18 @@ inherit distutils-r1
 
 DESCRIPTION="Low-level, data-driven core of boto 3."
 HOMEPAGE="https://github.com/boto/botocore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc test"
 
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/boto/botocore"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
 RDEPEND="
        >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
        >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]