app-office/grisbi: bump to 1.2.1
authorGuillaume Castagnino <casta@xwing.info>
Mon, 3 Dec 2018 10:38:29 +0000 (11:38 +0100)
committerRémi Cardona <remi@gentoo.org>
Sun, 31 Mar 2019 22:29:46 +0000 (00:29 +0200)
Add a second homepage. The second homepage points
directly to the official git repository

Closes: https://bugs.gentoo.org/show_bug.cgi?id=663392
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Guillaume Castagnino <casta@xwing.info>
Signed-off-by: Rémi Cardona <remi@gentoo.org>
app-office/grisbi/Manifest
app-office/grisbi/grisbi-1.2.1.ebuild [new file with mode: 0644]
app-office/grisbi/metadata.xml

index 01e35c2d0f4f947f73634bbd5ecc44a6b0f59784..d91390cb41721d88a34fb1be60d9a9cb0c790bec 100644 (file)
@@ -1 +1,2 @@
 DIST grisbi-1.0.4.tar.bz2 6965398 BLAKE2B f53b5cd7f2e4b0cdcf14732ba7e03315ec7d419c7f6ab3a290fd30a9dc9f7c0dde69b473dca3873aeb90b793cd90287c516f2fe4b7a50d71368abc3e12ce16f6 SHA512 9761ed94db563c39cab793ee076b6a729470231e3111d7ce57d188a6f1681cbb715174f67c15741320f295d4efdf0784f6e3d4d4d58267759efbad56561c7064
+DIST grisbi-1.2.1.tar.bz2 7314316 BLAKE2B b34aaaba79608561383e09fa1af7749f8c3cfa322f47a6d9cf350af1a3b96c575140246ed65b33127d92f84a57d959f24c99ef748ab80097ffce2ed8f16319aa SHA512 0193d5777ed191f7f3dac67fc9754f5588f35b9486567f3a7e7f9dd998865ff2130ad04b78a98dae1e1164fbd400a58328bdee777e9d0ff1100d1fd189a5aa2f
diff --git a/app-office/grisbi/grisbi-1.2.1.ebuild b/app-office/grisbi/grisbi-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..1cb4dfe
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org https://github.com/grisbi/grisbi"
+SRC_URI="mirror://sourceforge/${PN}/grisbi%20stable/1.2.x/${P}.tar.bz2"
+IUSE="goffice libressl nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       >=dev-libs/libxml2-2.5:2
+       >=dev-libs/glib-2.44.0:2
+       >=x11-libs/gtk+-3.20:3
+       x11-misc/xdg-utils
+       >=gnome-extra/libgsf-1.14
+       ssl? (
+               libressl? ( dev-libs/libressl:0= )
+               !libressl? ( >=dev-libs/openssl-1.0.0:0= ) )
+       ofx? ( >=dev-libs/libofx-0.9.0 )
+       goffice? ( >=x11-libs/goffice-0.10.0 )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --with-libxml2 \
+               --without-cunit \
+               --disable-static \
+               $(use_with ssl openssl) \
+               $(use_with ofx) \
+               $(use_with goffice) \
+               $(use_enable nls)
+}
index 105a80c6723c4ab221aceb5d8ce2892c0e1af5a1..b120f01ca373ed2a823b9eade306ef7b99534549 100644 (file)
@@ -19,4 +19,7 @@
        <upstream>
                <remote-id type="sourceforge">grisbi</remote-id>
        </upstream>
+       <use>
+               <flag name="goffice">enable goffice graphic support</flag>
+       </use>
 </pkgmetadata>