dev-python/wcwidth: python3_6 added
authorAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 13:04:34 +0000 (20:04 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 13:04:34 +0000 (20:04 +0700)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild b/dev-python/wcwidth/wcwidth-0.1.7-r1.ebuild
new file mode 100644 (file)
index 0000000..88fbfdc
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 5712ea6e8d0563cfbfecec3b894c63cd963647f4 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.python.org/pypi/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+       py.test -v -rs --strict wcwidth/tests || die
+}