Creating mp3 files with u+x attributes is just silly
---- file.c
-+++ file.c
+--- a/file.c
++++ b/file.c
@@ -136,3 +136,3 @@
file->fd = open(filename, O_WRONLY | O_CREAT | O_TRUNC,
- S_IRWXU | S_IRGRP | S_IROTH);
--- /dev/null
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ #
+ # 2005 bl0rg.net
+
+-CFLAGS += -Wall -O2
++CFLAGS += -Wall
+
+ # Uncomment these flags to add id3 support to mp3cue and mp3cut
+ #CFLAGS += -DWITH_ID3TAG
+@@ -352,8 +352,9 @@
+
+ USER ?= root
+ GROUP ?= root
+-PREFIX:= /usr/local
++PREFIX:= /usr
+ install: install-man
++ install -d -g root -o root $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3cue $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3cut $(DESTDIR)/$(PREFIX)/bin
+ install -g root -o root -m 0755 mp3length $(DESTDIR)/$(PREFIX)/bin
+@@ -367,6 +368,7 @@
+ install -g root -o root -m 0755 pogg-http $(DESTDIR)/$(PREFIX)/bin
+
+ install-man:
++ install -d -g root -o root $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3cue.1 $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3cut.1 $(DESTDIR)/$(PREFIX)/share/man/man1
+ install -g root -o root -m 0644 man/man1/mp3length.1 $(DESTDIR)/$(PREFIX)/share/man/man1
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="mp3 and ogg streamer (include mp3cue and mp3cut)"
HOMEPAGE="http://www.bl0rg.net/software/poc"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="sys-devel/flex
- sys-devel/bison"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CFLAGS/s:-O2::' \
- -e '/^PREFIX/s:/local::' \
- Makefile
- epatch "${FILESDIR}"/${P}-fec-pkt-prototype.patch
- epatch "${FILESDIR}"/${P}-file-perms.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed."
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-fec-pkt-prototype.patch
+ "${FILESDIR}"/${P}-file-perms.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc README TODO
+src_configure() {
+ tc-export CC
}