app-admin/keepassx: add missing handling of various cache updates, bug #577596
authorGilles Dartiguelongue <eva@gentoo.org>
Sat, 10 Sep 2016 13:16:36 +0000 (15:16 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 11 Sep 2016 10:58:21 +0000 (12:58 +0200)
With permission from poly-c.

Package-Manager: portage-2.3.0

app-admin/keepassx/keepassx-2.0.2-r1.ebuild [new file with mode: 0644]

diff --git a/app-admin/keepassx/keepassx-2.0.2-r1.ebuild b/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..519898f
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils vcs-snapshot xdg
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+       dev-libs/libgcrypt:0=
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-qt/qttest:4
+       sys-libs/zlib
+       x11-libs/libX11
+       x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(CHANGELOG)
+
+src_prepare() {
+       xdg_src_prepare
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DWITH_TESTS="$(usex test)"
+       )
+       cmake-utils_src_configure
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+       xdg_pkg_preinst
+}
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_pkg_postrm
+}