Don't inherit unused eclass. Properly set local variables. Patch by Arfrever.
authorMarkos Chandras <hwoarang@gentoo.org>
Fri, 6 Jan 2012 21:25:12 +0000 (21:25 +0000)
committerMarkos Chandras <hwoarang@gentoo.org>
Fri, 6 Jan 2012 21:25:12 +0000 (21:25 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

dev-python/wxpython/ChangeLog
dev-python/wxpython/wxpython-2.8.12.1.ebuild
dev-python/wxpython/wxpython-2.9.1.1.ebuild

index fe70ba4294298199c961b6c8f4d48c9a476a9e8d..3735c330eb8759ccf372c4f762be983df7ba081e 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-python/wxpython
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.153 2011/12/09 15:34:23 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.154 2012/01/06 21:25:12 hwoarang Exp $
+
+  06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> wxpython-2.8.12.1.ebuild,
+  wxpython-2.9.1.1.ebuild:
+  Don't inherit unused eclass. Properly set local variables. Patch by Arfrever.
 
   09 Dec 2011; Samuli Suominen <ssuominen@gentoo.org>
   -files/scripts-multiver-2.6.1.0.diff, -wxpython-2.6.4.0-r2.ebuild:
index e9505c3eadbc04e77390ef9262ef0c4ae848397f..929a022501b5f07702dfcd48c14aba1fb346084d 100644 (file)
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.1 2011/12/09 05:04:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.2 2012/01/06 21:25:12 hwoarang Exp $
 
 EAPI="4"
 PYTHON_DEPEND="2"
 WX_GTK_VER="2.8"
 SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
 
-inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+inherit alternatives eutils fdo-mime flag-o-matic python wxwidgets
 
 MY_P="${P/wxpython-/wxPython-src-}"
 
@@ -38,8 +39,6 @@ RDEPEND="
 DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
 S="${WORKDIR}/${MY_P}/wxPython"
 DOC_S="${WORKDIR}/wxPython-${PV}"
 
@@ -84,7 +83,7 @@ src_compile() {
 }
 
 src_install() {
-       local docdir mypyconf
+       local docdir file mypyconf
 
        mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
        use opengl \
index 5cb866a5482a3cd9bc79c5a1964647b1ff62550b..87ffceb9b51521b4bd1a8b23568952ad5d6ba1a8 100644 (file)
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.1.1.ebuild,v 1.3 2011/04/21 01:20:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.1.1.ebuild,v 1.4 2012/01/06 21:25:12 hwoarang Exp $
 
 EAPI="3"
 PYTHON_DEPEND="2"
 WX_GTK_VER="2.9"
 SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
 
-inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+inherit alternatives eutils fdo-mime flag-o-matic python wxwidgets
 
 MY_P="${P/wxpython-/wxPython-src-}"
 
@@ -36,8 +37,6 @@ RDEPEND="
 DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
 S="${WORKDIR}/${MY_P}/wxPython"
 DOC_S="${WORKDIR}/wxPython-${PV}"
 
@@ -77,7 +76,7 @@ src_compile() {
 }
 
 src_install() {
-       local mypyconf
+       local file mypyconf
 
        mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
        use opengl \