app-crypt/acme: 1.3.0 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 4 Apr 2020 20:14:26 +0000 (15:14 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 4 Apr 2020 21:05:41 +0000 (16:05 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/acme/Manifest
app-crypt/acme/acme-1.2.0.ebuild [deleted file]
app-crypt/acme/acme-1.3.0.ebuild

index 3103676a18efb3f69eb97c1eb3ec7a966b66a907..c6644fcb5db8c7ca12540b49f72283f327e4dddd 100644 (file)
@@ -1,2 +1 @@
-DIST certbot-1.2.0.tar.gz 1354262 BLAKE2B 1abdf4cb99ecdac6b9b8d2ebdd6897a3182a147f0175e2db4c6b0feaa3f6c615ee3146dd63627a83266c223456c5aba44b018be4059574d0209aec89065d9925 SHA512 ed52a31a71b3762b8cd217ea2784d9cb01f7c1a50cef3b7e0d99483ca3ab623b90ab7d4896674e0d1c06e2e8370c02162418d934de7d3048b0471416616146fe
 DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
diff --git a/app-crypt/acme/acme-1.2.0.ebuild b/app-crypt/acme/acme-1.2.0.ebuild
deleted file mode 100644 (file)
index db4f214..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
-
-if [[ ${PV} == 9999* ]]; then
-       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
-       inherit git-r3
-       S=${WORKDIR}/${P}/${PN}
-else
-       SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
-       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-       S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
-       >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
-       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
-       dev-python/mock[${PYTHON_USEDEP}]
-       >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
-       dev-python/pyrfc3339[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.10[${PYTHON_USEDEP}]
-       >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-xdist[${PYTHON_USEDEP}]
-       )
-       >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-src_compile() {
-       python_foreach_impl run_in_build_dir default
-       if use doc ; then
-               cd docs || die
-               sphinx-build -b html -d _build/doctrees   . _build/html
-       fi
-}
-
-python_test() {
-       nosetests -w ${PN} || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}
index 4aaf884c944a74b887941063c9c720f3d692ac57..db4f214816dc3b70343f9ea6cb5384adf523a603 100644 (file)
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]]; then
        S=${WORKDIR}/${P}/${PN}
 else
        SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+       KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
        S=${WORKDIR}/certbot-${PV}/acme
 fi