app-crypt/acr38u: eapi bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 4 Feb 2017 11:28:29 +0000 (13:28 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 4 Feb 2017 20:06:36 +0000 (22:06 +0200)
Package-Manager: portage-2.3.3

app-crypt/acr38u/acr38u-1.7.11-r3.ebuild

index 4c4104b8b7b3c2dfe1d8150ad8aa672b1b2296a6..ea4ac8d8cfdb61f1a1e6c90dc8db912a4bd69f8e 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-inherit multilib eutils versionator toolchain-funcs udev autotools-utils
+inherit autotools versionator toolchain-funcs udev
 
 MY_P=ACR38_LINUX_$(get_version_component_range 1)00$(get_version_component_range 2)$(get_version_component_range 3)_P
 
@@ -33,11 +33,18 @@ S=${WORKDIR}/${MY_P}
 
 IUSE=""
 
-AUTOTOOLS_AUTORECONF=yes
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
 
 src_install() {
-       autotools-utils_src_install
+       default
+       prune_libtool_files --modules
 
        # note: for eudev support this pkg may always need to install rules to /usr
        udev_newrules "${FILESDIR}"/${PV}-bis.rules 92-pcscd-acr38u.rules