net-dns/hash-slinger: Switch to python-single-r1
authorMichał Górny <mgorny@gentoo.org>
Sat, 8 Feb 2020 11:32:13 +0000 (12:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 15:54:19 +0000 (16:54 +0100)
Use python-single-r1 since the dep net-dns/unbound is single-r1.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
net-dns/hash-slinger/hash-slinger-2.7-r2.ebuild [moved from net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild with 67% similarity]

index a2ff821691bc8b6a9f218e18d839ac5f3e41d7e5..a5e14629412ab5799253e9efd3359bc761e6e7f6 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-r1
+inherit python-single-r1
 
 DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
 HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
@@ -21,12 +21,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 DEPEND=""
 RDEPEND="
        ${PYTHON_DEPS}
-       dev-python/dnspython[$PYTHON_USEDEP]
-       dev-python/ipaddr[$PYTHON_USEDEP]
-       dev-python/m2crypto[$PYTHON_USEDEP]
-       net-dns/unbound[python,$PYTHON_USEDEP]
+       net-dns/unbound[python,${PYTHON_SINGLE_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/dnspython[${PYTHON_MULTI_USEDEP}]
+               dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+               dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+               openpgp? ( dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}] )
+       ')
        ipsec? ( net-vpn/libreswan[dnssec] )
-       openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
        ssh? ( net-misc/openssh )
 "
 
@@ -38,7 +40,7 @@ src_install() {
        use ipsec && tools+=" ipseckey"
        for tool in $tools ; do
                doman ${tool}.1
-               python_foreach_impl python_doscript ${tool}
+               python_doscript ${tool}
        done
        dodoc BUGS CHANGES README
 }
similarity index 67%
rename from net-dns/hash-slinger/hash-slinger-2.7-r1.ebuild
rename to net-dns/hash-slinger/hash-slinger-2.7-r2.ebuild
index 161c87a31f2d940a19f6a6251b6101cc54865327..e36c1758e267167d58dd913c80e0758f5fc91787 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-r1
+inherit python-single-r1
 
 DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
 HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
@@ -21,12 +21,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 DEPEND=""
 RDEPEND="
        ${PYTHON_DEPS}
-       dev-python/dnspython[$PYTHON_USEDEP]
-       dev-python/ipaddr[$PYTHON_USEDEP]
-       dev-python/m2crypto[$PYTHON_USEDEP]
-       net-dns/unbound[python,$PYTHON_USEDEP]
+       net-dns/unbound[python,${PYTHON_SINGLE_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/dnspython[${PYTHON_MULTI_USEDEP}]
+               dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+               dev-python/m2crypto[${PYTHON_MULTI_USEDEP}]
+               openpgp? ( dev-python/python-gnupg[${PYTHON_MULTI_USEDEP}] )
+       ')
        ipsec? ( net-vpn/libreswan[dnssec] )
-       openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
        ssh? ( net-misc/openssh )
 "
 
@@ -38,7 +40,7 @@ src_install() {
        use ipsec && tools+=" ipseckey"
        for tool in $tools ; do
                doman ${tool}.1
-               python_foreach_impl python_doscript ${tool}
+               python_doscript ${tool}
        done
        dodoc BUGS CHANGES README
 }