version bump
authorPetre Rodan <kaiowas@gentoo.org>
Wed, 15 Nov 2006 17:42:31 +0000 (17:42 +0000)
committerPetre Rodan <kaiowas@gentoo.org>
Wed, 15 Nov 2006 17:42:31 +0000 (17:42 +0000)
Package-Manager: portage-2.1.1-r1

net-analyzer/nepenthes/ChangeLog
net-analyzer/nepenthes/files/digest-nepenthes-0.2.0 [new file with mode: 0644]
net-analyzer/nepenthes/nepenthes-0.2.0.ebuild [new file with mode: 0644]

index e3d3fa36fef88b23e383e9879c9f6c5cb8710ebe..a2cd38d7edf8931459f1152f4d7e1d986170f8eb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/nepenthes
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.12 2006/05/03 10:51:27 kaiowas Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.13 2006/11/15 17:42:31 kaiowas Exp $
+
+*nepenthes-0.2.0 (15 Nov 2006)
+
+  15 Nov 2006; Petre Rodan <kaiowas@gentoo.org> -nepenthes-0.1.6.ebuild,
+  +nepenthes-0.2.0.ebuild:
+  version bump
 
 *nepenthes-0.1.7-r1 (03 May 2006)
 
diff --git a/net-analyzer/nepenthes/files/digest-nepenthes-0.2.0 b/net-analyzer/nepenthes/files/digest-nepenthes-0.2.0
new file mode 100644 (file)
index 0000000..6b0e0e8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b06c4870c78e26e65961c03ccafa00ef nepenthes-0.2.0.tar.bz2 555866
+RMD160 d11c1c016aaf228ce8672c0cc62edb0dfb34e255 nepenthes-0.2.0.tar.bz2 555866
+SHA256 355ea137443e0c12d4e77a8adf5215ce24dcea020781c6840ac48abf0851202e nepenthes-0.2.0.tar.bz2 555866
diff --git a/net-analyzer/nepenthes/nepenthes-0.2.0.ebuild b/net-analyzer/nepenthes/nepenthes-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..c5a0721
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.0.ebuild,v 1.1 2006/11/15 17:42:31 kaiowas Exp $
+
+inherit eutils
+
+DESCRIPTION="Nepenthes is a low interaction honeypot that captures worms by emulating known vulnerabilities"
+HOMEPAGE="http://nepenthes.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="selinux"
+
+DEPEND="net-misc/curl
+       sys-apps/file
+       dev-libs/libpcre
+       net-libs/adns"
+
+RDEPEND=""
+#RDEPEND=" selinux? ( sec-policy/selinux-nepenthes )"
+
+pkg_setup() {
+       enewgroup nepenthes
+       enewuser nepenthes -1 -1 /dev/null nepenthes
+}
+
+src_compile() {
+       local myconf="--sysconfdir=/etc --localstatedir=/var/lib/nepenthes --enable-capabilities"
+       econf ${myconf} || die
+       sed -i 's|var/cache|/var/lib/cache|' ${S}/modules/shellcode-signatures/shellcode-signatures.cpp
+       emake || die "make failed"
+}
+
+src_install() {
+
+       einstall || die "make install failed"
+
+       for i in ${D}/etc/nepenthes/*; do
+               sed -i \
+                       -e 's|"var/binaries|"/var/lib/nepenthes/binaries|' \
+                       -e 's|"var/hexdumps|"/var/lib/nepenthes/hexdumps|' \
+                       -e 's|"var/cache/nepenthes|"/var/lib/nepenthes/cache|' \
+                       -e 's|"var/log|"/var/log/nepenthes|' \
+                       -e 's|"lib/nepenthes|"/usr/lib/nepenthes|' \
+                       -e 's|"etc|"/etc|' $i
+       done
+
+       dodoc doc/README doc/README.VFS AUTHORS
+       dosbin nepenthes-core/src/nepenthes || die "dosbin failed"
+       rm ${D}/usr/bin/nepenthes
+       rm ${D}/usr/share/doc/README
+       rm ${D}/usr/share/doc/README.VFS
+       rm ${D}/usr/share/doc/logo-shaded.svg
+
+       newinitd ${FILESDIR}/${PN}.initd ${PN}
+       newconfd ${FILESDIR}/${PN}.confd ${PN}
+
+       diropts -m 755 -o nepenthes -g nepenthes
+       keepdir /var/log/nepenthes
+       keepdir /var/lib/nepenthes
+       keepdir /var/lib/nepenthes/binaries
+       keepdir /var/lib/nepenthes/hexdumps
+       keepdir /var/lib/nepenthes/cache
+       keepdir /var/lib/nepenthes/cache/geolocation
+
+}
+