Adding linux-headers compile fix wrt bug #144205 thanks to Bo Orsted Andresen
authorMarkus Ullmann <jokey@gentoo.org>
Tue, 10 Oct 2006 13:47:19 +0000 (13:47 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Tue, 10 Oct 2006 13:47:19 +0000 (13:47 +0000)
Package-Manager: portage-2.1.2_pre2-r6

net-analyzer/iptraf/ChangeLog
net-analyzer/iptraf/files/iptraf-3.0.0-headerfix.patch
net-analyzer/iptraf/files/iptraf-3.0.0-ipv6-headerfix.patch

index 798ae26e7e5e90fbc35a56c714dcdee386cb05ce..d1876f06a7592c9955cd27e422c54c72aaf0d61a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/iptraf
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.40 2006/09/16 15:12:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.41 2006/10/10 13:47:19 jokey Exp $
+
+  10 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+  files/iptraf-3.0.0-headerfix.patch,
+  files/iptraf-3.0.0-ipv6-headerfix.patch, -iptraf-2.7.0-r2.ebuild,
+  -iptraf-3.0.0-r1.ebuild:
+  Adding linux-headers compile fix wrt bug #144205 thanks to Bo Orsted Andresen
 
   16 Sep 2006; Markus Rothe <corsair@gentoo.org> iptraf-3.0.0-r2.ebuild:
   Added ~ppc64
index 7ce5e7c66eb9d23dc7dccc3c165f91843e905e0f..604d63e26f173d54464727b8942400f4a4eaf5f3 100644 (file)
@@ -1,6 +1,17 @@
-diff -urN ./iptraf-3.0.0.orig/src/tr.c ./iptraf-3.0.0/src/tr.c
---- ./iptraf-3.0.0.orig/src/tr.c       2005-09-13 08:42:54.000000000 +0200
-+++ ./iptraf-3.0.0/src/tr.c    2006-04-16 00:20:06.000000000 +0200
+diff -Naur iptraf-3.0.0-minus/src/othptab.c iptraf-3.0.0/src/othptab.c
+--- iptraf-3.0.0-minus/src/othptab.c   2006-09-27 03:30:33.000000000 +0200
++++ iptraf-3.0.0/src/othptab.c 2006-09-27 03:34:24.000000000 +0200
+@@ -17,6 +17,7 @@
+ ***/
+ #include <asm/types.h>
++#include <sys/types.h>
+ #include <linux/if_ether.h>
+ #include <winops.h>
+ #include "arphdr.h"
+diff -Naur iptraf-3.0.0-minus/src/tr.c iptraf-3.0.0/src/tr.c
+--- iptraf-3.0.0-minus/src/tr.c        2005-09-13 08:42:54.000000000 +0200
++++ iptraf-3.0.0/src/tr.c      2006-09-27 03:32:54.000000000 +0200
 @@ -7,8 +7,8 @@
   */
  
@@ -11,3 +22,4 @@ diff -urN ./iptraf-3.0.0.orig/src/tr.c ./iptraf-3.0.0/src/tr.c
  
  unsigned int get_tr_ip_offset(unsigned char *pkt)
  {
+
index a2ec93eb6bce8669f27c9cbcd6073210200915cc..40b95f34a311a8ad282cbc701b4890f5dd02d4be 100644 (file)
@@ -2,9 +2,9 @@ diff -urN ./iptraf-3.0.0.orig/src/othptab.c ./iptraf-3.0.0/src/othptab.c
 --- ./iptraf-3.0.0.orig/src/othptab.c  2006-04-16 00:20:52.000000000 +0200
 +++ ./iptraf-3.0.0/src/othptab.c       2006-04-16 00:22:01.000000000 +0200
 @@ -17,9 +17,9 @@
- ***/
  
  #include <asm/types.h>
+ #include <sys/types.h>
 -#include <linux/if_ether.h>
  #include <netinet/ip6.h>
  #include <netinet/icmp6.h>