app-portage/tatt: version bump 0.7
authorMichael Palimaka <kensington@gentoo.org>
Tue, 3 Mar 2020 10:24:24 +0000 (21:24 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Tue, 3 Mar 2020 10:32:55 +0000 (21:32 +1100)
Bug: https://bugs.gentoo.org/711204
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
app-portage/tatt/Manifest
app-portage/tatt/tatt-0.7.ebuild [new file with mode: 0644]

index c095edbcb27ae776d0a204b1d5308de0f594bc8e..c4a11f1b889aa3a11a723bf610abe63c4e4c311f 100644 (file)
@@ -1,2 +1,3 @@
 DIST tatt-0.5.tar.gz 23249 BLAKE2B d98456bab4ec4d820bddc2ec614e02582f5b0385d806c876a5155cb09bd1468908ded3f5c879fc38f2cb4211f8415dddd640dd20b6b123c926b02387d49dced1 SHA512 0e2fa0dc12339be2ee2408a9dfa06201857bd2ef570b1c5ab46f0c4f0dc07492fc16d74c8f05cdef9232361b77843703d5f7e6752bff17a1ca2c3aa3cb1c1f29
 DIST tatt-0.6.tar.gz 21689 BLAKE2B d11bfb616cd27f1a303d4c95dec875cad42d31d72654be4649dac2c7b3f086b7c5a1886d9c9fbd0a858d9e042c9db0a7b5e2f4167c46b6291509f9d97a654097 SHA512 c12ea273af8b5bb410493f297776d730b7c36748a5f1b735c94dfb0542f9f03d28482060858951ac9fa161fc299c21473f5bdeaa4d89fb88ef61187a809dcac2
+DIST tatt-0.7.tar.gz 21802 BLAKE2B a0195f253e2777a8756fd7d1f83804bf3a4ca90fdeb07b2f8dc28dcb6f1d1f3c47fd948e0d001103f7972dc8cb8ee45a237dd24b3dc149392aa9841fe3d6532a SHA512 1f2a144512801d50585d40074553049ebd08bc5f084a0623b89d901acb9448657e7f42f2c8da5f613e0b2ff5c3fe59fbada1ad911c9693846923e256a2e97ecd
diff --git a/app-portage/tatt/tatt-0.7.ebuild b/app-portage/tatt/tatt-0.7.ebuild
new file mode 100644 (file)
index 0000000..870fa55
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+       app-portage/eix
+       app-portage/gentoolkit
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       www-client/pybugz
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use templates; then
+               insinto "/usr/share/${PN}"
+               doins -r templates
+       fi
+       doman tatt.1
+       doman tatt.5
+}