dev-libs/libixion: 0.11.0 version bump
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Fri, 19 Feb 2016 23:29:57 +0000 (00:29 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 22 Feb 2016 17:06:31 +0000 (18:06 +0100)
Package-Manager: portage-2.2.27

dev-libs/libixion/Manifest
dev-libs/libixion/libixion-0.11.0.ebuild [new file with mode: 0644]

index e1da979aa3725b1545101e267c2cef9ec0ed7880..f2e35ea40d5e371d9a5a609f89712a88c01084bc 100644 (file)
@@ -1,3 +1,4 @@
+DIST libixion-0.11.0.tar.xz 365652 SHA256 97a6e7f2b1fcbff69e76fe4e1df62f1cfcc353820472991e37de00aacb024293 SHA512 ebba456908c74d952256b7ba4b675ebbe0978e1cf39aa2fa03f0f11050fd874cfa8393f92f29cdf70d539bb6a11db94b639f81fdcbf14ee0d4de62236cd85d30 WHIRLPOOL cf0db731cdf6c70555036135eb5c22ad7abc327ff56223604922b7080abb7e31dd56cd9af8e397a4b0c7dac00f5901299a6ee0ff7044915d280b2f754667988e
 DIST libixion-0.7.0.tar.bz2 398089 SHA256 c9594ec93e911b40b26784ccdae47df8ea3a7d9b57bbad876733e4efcedf5581 SHA512 bda96a9cefb4bd842cd399a74c2fb5791d2a1d1d06d07106e1a121dc0bc02c00bef371b480ab1a7f922d5292c4d94fa8f7faaa2c6cd7596f2bc08b6ddfc929f5 WHIRLPOOL 0881a4b350eb6e8dc30ec166630cf46f85af07f41010b51b1b359787641d7f742ae10f1d4b1b3e438460bdb72468f43158c5baf1da95a0b70ed9d380c230f7d3
 DIST libixion-0.9.0.tar.xz 351388 SHA256 2112b4304667c4c2cdb8f3d331cc4ba696ea581db7d228b5b06ea2559e7531a5 SHA512 da6ca9e79841f1f529328e39a2977d95a261ddaaf4a254bfc46de004d52d4b1e8fc0c8c1cbeb3e8ee18e9a5663b046cf1d3f232f31bdd83db75a766be654f49b WHIRLPOOL f35087fce0a0e53650b988b36ecde8378aa75d2a4b769f6046dce544b9fe89a0025c82a6ab2564b5a12c813e0726875c088d5cc37cfcad055d79d2c5563d53af
 DIST libixion-0.9.1.tar.xz 356500 SHA256 77e35c163cd27657b83626a6da26c3b90f37ba9089d00aa25f384a9ac4b4e3a1 SHA512 074318c6db01ec13f6cbdfb8d7d04aede9f20cac4c23476b570a37638b0e68170aabf977520b94dfc2dce079314109c2e70d64376f9f314890d4d60854458c03 WHIRLPOOL ed79f0ed5705f8f8c5a24603fa4386b8822b477a21896d13eaf5fbe52d0f12fbf451f68de49314d8736160f82895047ba4d387431f989683553316d523bb0ce4
diff --git a/dev-libs/libixion/libixion-0.11.0.ebuild b/dev-libs/libixion/libixion-0.11.0.ebuild
new file mode 100644 (file)
index 0000000..0d63dd7
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit eutils python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.11" # based on SONAME of libixion.so
+[[ ${PV} == 9999 ]] || \
+KEYWORDS=""
+# KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="python static-libs"
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+       dev-util/mdds:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       eapply_user
+       [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable python) \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       prune_libtool_files --all
+}