net-libs/libmnl: port to EAPI 7
authorAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 02:38:19 +0000 (21:38 -0500)
committerAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 03:25:06 +0000 (22:25 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-libs/libmnl/libmnl-1.0.3-r1.ebuild
net-libs/libmnl/libmnl-1.0.4.ebuild

index 316073b5786eb53d388aed515423c285896e66ac..67fbdb2cc36faf0bb2aa96adae736eb534b417b6 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils toolchain-funcs usr-ldscript
+inherit toolchain-funcs usr-ldscript
 
 DESCRIPTION="Minimalistic netlink library"
 HOMEPAGE="https://netfilter.org/projects/libmnl/"
@@ -20,11 +20,13 @@ src_configure() {
 
 src_install() {
        default
+
        gen_usr_ldscript -a mnl
-       prune_libtool_files
+
+       find "${D}" -name '*.la' -delete || die
 
        if use examples; then
-               find examples/ -name 'Makefile*' -delete
+               find examples/ -name 'Makefile*' -delete || die
                dodoc -r examples/
                docompress -x /usr/share/doc/${PF}/examples
        fi
index fd97a5559d2694287226a0d36fcf2714b4cb4e7f..794d9e309842e9d9664a81558326d5251890673c 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit eutils toolchain-funcs usr-ldscript
+inherit toolchain-funcs usr-ldscript
 
 DESCRIPTION="Minimalistic netlink library"
 HOMEPAGE="https://netfilter.org/projects/libmnl/"
@@ -22,10 +22,11 @@ src_install() {
        default
 
        gen_usr_ldscript -a mnl
-       prune_libtool_files
+
+       find "${D}" -name '*.la' -delete || die
 
        if use examples; then
-               find examples/ -name 'Makefile*' -delete
+               find examples/ -name 'Makefile*' -delete || die
                dodoc -r examples/
                docompress -x /usr/share/doc/${PF}/examples
        fi