dev-python/os-client-config: add version 1.6.3
authorAlex Brandt <alunduil@gentoo.org>
Sun, 16 Aug 2015 23:04:41 +0000 (18:04 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sun, 16 Aug 2015 23:05:07 +0000 (18:05 -0500)
Package-Manager: portage-2.2.20.1

dev-python/os-client-config/Manifest
dev-python/os-client-config/os-client-config-1.6.3.ebuild [new file with mode: 0644]

index ddc867bdae18f40f0565c811182277e332d0e0e5..b11b002b00ff6f4192fcc48c92a4fc60d525f7e2 100644 (file)
@@ -1 +1,2 @@
 DIST os-client-config-1.6.1.tar.gz 28783 SHA256 24323a33fe4ec4ff0c71a91aa16d26f4c4320f0b0234c5ac22d08f99e2f5c24d SHA512 3f71b17d70f2e7a75e6530203f84a5d32d9bb8c517d1379033ad5fb1d864bcb58c2b026bd2f177fe415b6c03498518bb5abb23df710c66ffd828619aeaf2a4f4 WHIRLPOOL 326c912ae153ad0bcbc7988743be880cb4b7be17762fee8a7ae82946f3502ca9085d0f17726c7d5f7aec4a81968d134674dfc55de3a14d91773279c66db445cb
+DIST os-client-config-1.6.3.tar.gz 25695 SHA256 c7bf7c91bd99e9501a6a2e5415ce4026f0d022d5df9d6123bc935db6108a423f SHA512 411e32c38fec5146eaf01c9fa0f7e1c5ff61c35847604ae2d3a4316a06bfc1b86be83166bf6cd0debef3a352483ee9119471e7a535ff01e264c42f516499b3b4 WHIRLPOOL 5799f8f4ac684e389888c0f5511d5c11ae39dde038d53b74deb29508b0d631cb17e72ea94bf4a343c5f7816aae5f92e19c53d490f46f40c723be69b82d543c65
diff --git a/dev-python/os-client-config/os-client-config-1.6.3.ebuild b/dev-python/os-client-config/os-client-config-1.6.3.ebuild
new file mode 100644 (file)
index 0000000..1ef8b3f
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Client Configuation Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               dev-python/extras[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+               <dev-python/oslotest-1.6.0[${PYTHON_USEDEP}]
+               >=dev-python/python-keystoneclient-1.1.0[${PYTHON_USEDEP}]
+               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+               !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               <dev-python/oslo-sphinx-2.6.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       local PATCHES=(
+               "${FILESDIR}"/test_get_all_clouds.patch
+       )
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       distutils_install_for_testing
+
+       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+}