net-dns/avahi: version bump to 0.8
authorAnthony G. Basile <blueness@gentoo.org>
Wed, 11 Mar 2020 00:58:46 +0000 (20:58 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Wed, 11 Mar 2020 00:59:42 +0000 (20:59 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-dns/avahi/Manifest
net-dns/avahi/avahi-0.8.ebuild [new file with mode: 0644]

index 6bf6b289a81b8d43d83adf5d2108a9eff6b31216..8c49f959d60f42700a5a69b3ee89be94afe90b35 100644 (file)
@@ -1 +1,2 @@
 DIST avahi-0.7.tar.gz 940047 BLAKE2B 8299577bf27ee65fad5d743dbf94202b148a6fc86825cae303f94c44482eea07cf6570d970ca286e81a787d6a64598b7123f2ac17a259ddc50ef431b9c94b530 SHA512 61f656da7614d8cca1862180038f571db3474c84f05db4d3509f614cdbf8b1a1047661b7e24d63682d5b48ed1bfa1b08b3c9e6dbe9222bcd62d99bc168a11abe
+DIST avahi-0.8.tar.gz 953319 BLAKE2B ddede1b8790ff3057ea5f4bb710e95578229e078a7abac83121e043017dda1ab3d971c723f920fdd4f3d98b88bd2cf21f9645bec1b7bbd2ea194cb399a5f5b46 SHA512 27bba9a551152dfc7e721f326042e7bfce55d227044a6cbaee04d6fb0e3f59c36e159c2b7a4dd42d1c955cdf37cc1c303e91991c08928bbded91d796e9a22abe
diff --git a/net-dns/avahi/avahi-0.8.ebuild b/net-dns/avahi/avahi-0.8.ebuild
new file mode 100644 (file)
index 0000000..c09f0b1
--- /dev/null
@@ -0,0 +1,222 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="gdbm"
+inherit autotools flag-o-matic multilib-minimal mono-env python-r1 systemd
+
+DESCRIPTION="System which facilitates service discovery on a local network"
+HOMEPAGE="http://avahi.org/"
+SRC_URI="https://github.com/lathiat/avahi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="autoipd bookmarks dbus doc gdbm gtk gtk3 howl-compat +introspection ipv6 kernel_linux mdnsresponder-compat mono nls python qt5 selinux systemd test"
+
+REQUIRED_USE="
+       python? ( dbus gdbm ${PYTHON_REQUIRED_USE} )
+       mono? ( dbus )
+       howl-compat? ( dbus )
+       mdnsresponder-compat? ( dbus )
+       systemd? ( dbus )
+"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-libs/libdaemon
+       dev-libs/libevent:=
+       dev-libs/expat
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       gdbm? ( sys-libs/gdbm:=[${MULTILIB_USEDEP}] )
+       qt5? ( dev-qt/qtcore:5 )
+       gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )
+       gtk3? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+       dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+       kernel_linux? ( sys-libs/libcap )
+       introspection? ( dev-libs/gobject-introspection:= )
+       mono? (
+               dev-lang/mono
+               gtk? ( dev-dotnet/gtk-sharp:2 )
+       )
+       python? (
+               ${PYTHON_DEPS}
+               dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+               introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )
+       )
+       bookmarks? (
+               ${PYTHON_DEPS}
+               >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       acct-user/avahi
+       acct-group/avahi
+       acct-group/netdev
+       autoipd? (
+               acct-user/avahi-autoipd
+               acct-group/avahi-autoipd
+       )
+       ${DEPEND}
+       howl-compat? ( !net-misc/howl )
+       mdnsresponder-compat? ( !net-misc/mDNSResponder )
+       selinux? ( sec-policy/selinux-avahi )
+"
+BDEPEND="
+       dev-util/glib-utils
+       doc? ( app-doc/doxygen )
+       app-doc/xmltoman
+       dev-util/intltool
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/avahi-qt5/qt-watch.h )
+
+# These patches do not apply cleanly but may need to be re-instated.
+# I'll leave them commented out for now.
+#PATCHES=(
+#      "${FILESDIR}/${PN}-0.7-qt5.patch"
+#      "${FILESDIR}/${PN}-0.7-CVE-2017-6519.patch"
+#      "${FILESDIR}/${PN}-0.7-remove-empty-avahi_discover.patch"
+#      "${FILESDIR}/${PN}-0.7-python3.patch"
+#      "${FILESDIR}/${PN}-0.7-python3-unittest.patch"
+#      "${FILESDIR}/${PN}-0.7-python3-gdbm.patch"
+#)
+
+pkg_setup() {
+       use mono && mono-env_pkg_setup
+       use python || use bookmarks && python_setup
+}
+
+src_prepare() {
+       default
+
+       if ! use ipv6; then
+               sed -i \
+                       -e "s/use-ipv6=yes/use-ipv6=no/" \
+                       avahi-daemon/avahi-daemon.conf || die
+       fi
+
+       sed -i \
+               -e "s:\\.\\./\\.\\./\\.\\./doc/avahi-docs/html/:../../../doc/${PF}/html/:" \
+               doxygen_to_devhelp.xsl || die
+
+       eautoreconf
+
+       # bundled manpages
+       multilib_copy_sources
+}
+
+src_configure() {
+       # those steps should be done once-per-ebuild rather than per-ABI
+       use sh && replace-flags -O? -O0
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local myconf=(
+               --disable-monodoc
+               --disable-python-dbus
+               --disable-qt3
+               --disable-qt4
+               --disable-static
+               --enable-manpages
+               --enable-glib
+               --enable-gobject
+               --enable-xmltoman
+               --localstatedir="${EPREFIX}/var"
+               --with-distro=gentoo
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+               $(use_enable dbus)
+               $(use_enable gdbm)
+               $(use_enable gtk)
+               $(use_enable gtk3)
+               $(use_enable howl-compat compat-howl)
+               $(use_enable mdnsresponder-compat compat-libdns_sd)
+               $(use_enable nls)
+               $(multilib_native_use_enable autoipd)
+               $(multilib_native_use_enable doc doxygen-doc)
+               $(multilib_native_use_enable introspection)
+               $(multilib_native_use_enable mono)
+               $(multilib_native_use_enable python)
+               $(multilib_native_use_enable test tests)
+       )
+
+       if use python; then
+               myconf+=(
+                       $(multilib_native_use_enable dbus python-dbus)
+                       $(multilib_native_use_enable introspection pygobject)
+               )
+       fi
+
+       if use mono; then
+               myconf+=( $(multilib_native_use_enable doc monodoc) )
+       fi
+
+       if ! multilib_is_native_abi; then
+               myconf+=(
+                       # used by daemons only
+                       --disable-libdaemon
+                       --with-xml=none
+               )
+       fi
+
+       myconf+=( $(multilib_native_use_enable qt5) )
+
+       econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+       emake
+
+       multilib_is_native_abi && use doc && emake avahi.devhelp
+}
+
+multilib_src_install() {
+       emake install DESTDIR="${D}"
+       use bookmarks && use python && use dbus && use gtk || \
+               rm -f "${ED}"/usr/bin/avahi-bookmarks
+
+       # https://github.com/lathiat/avahi/issues/28
+       use howl-compat && dosym avahi-compat-howl.pc /usr/$(get_libdir)/pkgconfig/howl.pc
+       use mdnsresponder-compat && dosym avahi-compat-libdns_sd/dns_sd.h /usr/include/dns_sd.h
+
+       if multilib_is_native_abi && use doc; then
+               docinto html
+               dodoc -r doxygen/html/.
+               insinto /usr/share/devhelp/books/avahi
+               doins avahi.devhelp
+       fi
+
+       # The build system creates an empty "/run" directory, so we clean it up here
+       rmdir "${ED}"/run || die
+}
+
+multilib_src_install_all() {
+       if use autoipd; then
+               insinto /lib/rcscripts/net
+               doins "${FILESDIR}"/autoipd.sh
+
+               insinto /lib/netifrc/net
+               newins "${FILESDIR}"/autoipd-openrc.sh autoipd.sh
+       fi
+
+       dodoc docs/{AUTHORS,NEWS,README,TODO}
+
+       find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+       if use autoipd; then
+               elog
+               elog "To use avahi-autoipd to configure your interfaces with IPv4LL (RFC3927)"
+               elog "addresses, just set config_<interface>=( autoipd ) in /etc/conf.d/net!"
+               elog
+       fi
+
+       systemd_reenable avahi-daemon.service
+}