x11-libs/libdrm: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Sat, 21 Sep 2019 17:06:42 +0000 (10:06 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 21 Sep 2019 17:11:47 +0000 (10:11 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libdrm/Manifest
x11-libs/libdrm/libdrm-2.4.97.ebuild [deleted file]

index 6702054cc3ca8b60fd9240a86ff84b64c0c3f7c7..e04389eb08d342d74293b2b8acb91ee0da8e2e66 100644 (file)
@@ -1,2 +1 @@
-DIST libdrm-2.4.97.tar.bz2 837329 BLAKE2B b47393d81917a0b43c22f7798ff2e1c21a05fc716a63092dbe0e49cda0fe3bd899d5cc4d703ae49f781e283f5067c62cd37a4931362427e21c3356584cb5e810 SHA512 3e08ee9d6c9ce265d783a59b51e22449905ea73aa27f25a082a1e9e1532f7c99e1c9f7cb966eb0970be2a08e2e5993dc9aa55093b1bff548689fdb465e7145ed
 DIST libdrm-2.4.99.tar.bz2 853659 BLAKE2B 66fb3f757ab468b6f6285ae740f67d6c38473f3866b57c6a1e24b322bdd46f2d21132b5ea7a737f1d3fa8dcf55162d4c904f181f17227c239b3322c0af50181c SHA512 04702eebe8dca97fac61653623804fdcb0b8b3714bdc6f5e72f0dfdce9c9524cf16f69d37aa9feac79ddc1c11939be44a216484563a612414668ea5eaeadf191
diff --git a/x11-libs/libdrm/libdrm-2.4.97.ebuild b/x11-libs/libdrm/libdrm-2.4.97.ebuild
deleted file mode 100644 (file)
index 76499a8..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
-
-if [[ ${PV} = 9999* ]]; then
-       GIT_ECLASS="git-r3"
-fi
-
-inherit ${GIT_ECLASS} meson multilib-minimal
-
-DESCRIPTION="X.Org libdrm library"
-HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
-if [[ ${PV} = 9999* ]]; then
-       SRC_URI=""
-else
-       SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
-for card in ${VIDEO_CARDS}; do
-       IUSE_VIDEO_CARDS+=" video_cards_${card}"
-done
-
-IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
-RESTRICT="test" # see bug #236845
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
-       video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
-       valgrind? ( dev-util/valgrind )"
-
-src_unpack() {
-       default
-       [[ $PV = 9999* ]] && git-r3_src_unpack
-}
-
-multilib_src_configure() {
-       local emesonargs=(
-               # Udev is only used by tests now.
-               -Dudev=false
-               -Dcairo-tests=false
-               -Damdgpu=$(usex video_cards_amdgpu true false)
-               -Dexynos=$(usex video_cards_exynos true false)
-               -Dfreedreno=$(usex video_cards_freedreno true false)
-               -Dintel=$(usex video_cards_intel true false)
-               -Dnouveau=$(usex video_cards_nouveau true false)
-               -Domap=$(usex video_cards_omap true false)
-               -Dradeon=$(usex video_cards_radeon true false)
-               -Dtegra=$(usex video_cards_tegra true false)
-               -Dvc4=$(usex video_cards_vc4 true false)
-               -Detnaviv=$(usex video_cards_vivante true false)
-               -Dvmwgfx=$(usex video_cards_vmware true false)
-               -Dlibkms=$(usex libkms true false)
-               # valgrind installs its .pc file to the pkgconfig for the primary arch
-               -Dvalgrind=$(usex valgrind auto false)
-       )
-       meson_src_configure
-}
-
-multilib_src_compile() {
-       meson_src_compile
-}
-
-multilib_src_test() {
-       meson_src_test
-}
-
-multilib_src_install() {
-       meson_src_install
-}