app-office/moneydance: bump to version 2019.3
authorConrad Kostecki <conrad@kostecki.com>
Sat, 6 Jul 2019 11:13:03 +0000 (13:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 8 Jul 2019 07:28:39 +0000 (09:28 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-office/moneydance/Manifest
app-office/moneydance/files/moneydance-bin [new file with mode: 0644]
app-office/moneydance/moneydance-2019.3.1880.ebuild [new file with mode: 0644]

index 2526a779f467bf1a95b2860b85fcffb718cd06bb..335576873a62e0ae83895deb94fc07f5bf63a05a 100644 (file)
@@ -1,3 +1,4 @@
 DIST moneydance-2017.10-amd64.tar.gz 132116528 BLAKE2B f5ba44a89944657c6c1380226dc512729825b084783e6d70dd7b2b731411294c7333bae858b2be3d5321e5145230257b325dc2b72a22744a877673c1c934d854 SHA512 175ff470b5fb5c3851eae708cc641777d7bdf1ede40366ccf5a135d6c813c08d9ce32665a2307c3aefa63eeb2206ad0874cb989aa998415abb86184a2b114ce8
 DIST moneydance-2017.10-x86.tar.gz 134860964 BLAKE2B 92181a6c6a81063377823b0fd9ed652036cf1f633c2cab57f19d1dbb18a2542361fc2bafab8852c11b941a24532f662351ea2d05bc928818db24a4cf3cae7112 SHA512 18d9d4ce7b0b65566ac81fea66ba34d66173559ca90ac166cc9b90631400845ae1c9d92ae781a618cacc57cd4f630f079736101d29b66d9c6cee7d32c7c15c22
 DIST moneydance-2019.1-amd64.tar.gz 132469388 BLAKE2B 516ff3af46e23370cf97b7a41e9802f14f5272c36b01080d69f339bdb9ca7de045de35baead8d97a8febece062dcd8b2befecad2744773e9a1c79b9a16b9639a SHA512 a28787dcc10173f4d492ec1bd5a8f17b6592f86c324e57a7e2951a0265825e4f78b620a4aabb4cde94c97860d3aaac8066572882c772d5abfa79c90cd33770ee
+DIST moneydance-2019.3.1880-amd64.tar.gz 134414524 BLAKE2B fa6991b245efb76d9af17611ce5f24c4c77fe171417f41ccdccccbfa0b6795fbcb1c56c072dc7382e85f81ec57302040eb0cb091162964026fd230e6b5b3eecd SHA512 1e0cedb759168123de357cf4f69691ac4bd9868524d012f924d00c8f653a3505d3defe8c79e0c151d2b9163dfa40b551b0cc86fd7da678e841902bab812a1d2c
diff --git a/app-office/moneydance/files/moneydance-bin b/app-office/moneydance/files/moneydance-bin
new file mode 100644 (file)
index 0000000..1e8089e
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Options
+JAVA_OPTS="-client -Dawt.useSystemAAFontSettings=gasp -Dawt.useSystemAAFontSettings=on -Xmx2048m"
+MONEYDANCE_LIBS="/usr/share/moneydance/lib"
+
+# Choose JAVA
+set -- /opt/openjdk-bin-11.* /usr/lib*/openjdk-11
+while ! [ -d "${1}" ]; do
+       if [ ${#} -eq 1 ]; then
+               echo "Error: No JAVA 11 runtime found!"
+               exit 1
+       fi
+
+       shift
+done
+JAVA_HOME="${1}"
+
+# Set CLASSPATH
+for MONEYDANCE_JAR in ${MONEYDANCE_LIBS}/*.jar; do
+       CLASSPATH=${CLASSPATH}:${MONEYDANCE_JAR}
+done
+
+# Launch Moneydance
+"${JAVA_HOME}"/bin/java -cp "${CLASSPATH}" ${JAVA_OPTS} Moneydance
diff --git a/app-office/moneydance/moneydance-2019.3.1880.ebuild b/app-office/moneydance/moneydance-2019.3.1880.ebuild
new file mode 100644 (file)
index 0000000..7b33f49
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop eapi7-ver java-pkg-2 xdg-utils
+
+MY_PN="Moneydance"
+MY_PV="$(ver_cut 1-2)_$(ver_cut 3)"
+
+DESCRIPTION="A cross-platform personal finance application"
+HOMEPAGE="https://moneydance.com/"
+SRC_URI="https://infinitekind.com/stabledl/${MY_PV}/${MY_PN}_linux_amd64.tar.gz -> ${P}-amd64.tar.gz"
+
+LICENSE="Apache-1.0 Apache-2.0 BSD CPAL-1.0 CPL-1.0 CSL-2.0 LGPL-2 MIT TIK"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="|| (
+               >=dev-java/openjdk-bin-11.0
+               >=dev-java/openjdk-11.0
+       )
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+RESTRICT="bindist fetch mirror"
+
+pkg_nofetch() {
+       elog "Please download ${A} from"
+       elog "https://infinitekind.com/stabledl/${MY_PV}/${MY_PN}_linux_amd64.tar.gz"
+       elog "and place it in your DISTDIR directory."
+       elog ""
+       elog "Please keep in mind, that you have to rename the download to ${P}-amd64.tar.gz."
+}
+
+src_compile() {
+       :;
+}
+
+src_install() {
+       java-pkg_dojar lib/*.jar
+
+       newbin "${FILESDIR}/moneydance-bin" moneydance
+
+       local iconsizes="32 128 512"
+       for iconsize in ${iconsizes}; do
+               newicon -s ${iconsize} resources/moneydance_icon${iconsize}.png moneydance.png
+       done
+
+       make_desktop_entry "moneydance" "Moneydance" moneydance Office
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}