dev-python/pytest-forked: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:37:56 +0000 (19:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 18:48:33 +0000 (19:48 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-forked/pytest-forked-1.1.3.ebuild

index d4f6a216d5cb747026cc5574629cf4fb570956b4..ad0382bac2ef15fb7e81b8848d765ca2d960868a 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
@@ -21,7 +22,6 @@ RDEPEND="
        >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]"
 
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/setuptools_scm[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} )"