xfce-base/libxfcegui4: remove obsolete xfconf.eclass, migrate to EAPI6
authorDenis Dupeyron <calchan@gentoo.org>
Wed, 29 Nov 2017 19:15:33 +0000 (19:15 +0000)
committerDenis Dupeyron <calchan@gentoo.org>
Wed, 29 Nov 2017 19:15:33 +0000 (19:15 +0000)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

xfce-base/libxfcegui4/Manifest
xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild [new file with mode: 0644]

index ebdd7fa89c8f0e66003ddb0f024d07579d9fda29..e8213f6be7958447f75bb12386964b3f0246cf09 100644 (file)
@@ -1 +1 @@
-DIST libxfcegui4-4.10.0.tar.bz2 691012 SHA256 2b82f9979175d8856880c8f349e6eede491ca92fe6940c69c8958115418d4533 SHA512 32fe3be287c84d1816154c7632a87025324c2cb9d9524ef3d7813c3b3619ca04e4b70aeb47a3e0fb59090e43e124476988774a0dc5186ebc1a0ccdfe635cbb45 WHIRLPOOL 7390c5d36bf2e3bdea6a8c7de4f9471be9f434e99a250c8925de8ae7fa69f307c43b029d52417118bf49764c0834cfb6b039320846b83488cb8d39ca79cc2e15
+DIST libxfcegui4-4.10.0.tar.bz2 691012 BLAKE2B cce4f0a9587c10c1a226550ddeda8a9f00b5c1306ce11c329c914e4f3240f4fdb390beb7a1aa7049076767c26707b2570c801ebb9d78504694ee3542477882eb SHA512 32fe3be287c84d1816154c7632a87025324c2cb9d9524ef3d7813c3b3619ca04e4b70aeb47a3e0fb59090e43e124476988774a0dc5186ebc1a0ccdfe635cbb45
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.10.0-r2.ebuild
new file mode 100644 (file)
index 0000000..7e4dd9b
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A compability library for unported Xfce 4.6 plugins (DEPRECATED)"
+HOMEPAGE="https://git.xfce.org/archive/libxfcegui4/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="startup-notification"
+
+RDEPEND="gnome-base/libglade
+       x11-libs/libSM
+       x11-libs/libX11
+       >=x11-libs/gtk+-2.10:2
+       >=xfce-base/libxfce4util-4.10
+       startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_prepare() {
+       eapply -p0 "${FILESDIR}"/${P}-no-xfce_setenv.patch
+       default
+}
+
+src_configure() {
+       local myconf=(
+               --disable-static
+               $(use_enable startup-notification)
+               # glade:3 no longer supported on Gentoo, #575166
+               --disable-gladeui
+               --with-html-dir="${EPREFIX}"/deprecated
+               )
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       rm -rf "${ED}"/deprecated
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}