media-sound/timidity-eawpatches: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:50 +0000 (00:37 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:50 +0000 (00:37 +0200)
Bug: https://bugs.gentoo.org/697272
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/timidity-eawpatches/files/timidity-eawpatches-12-fix-dir.patch [new file with mode: 0644]
media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild

diff --git a/media-sound/timidity-eawpatches/files/timidity-eawpatches-12-fix-dir.patch b/media-sound/timidity-eawpatches/files/timidity-eawpatches-12-fix-dir.patch
new file mode 100644 (file)
index 0000000..a41b0ea
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/linuxconfig/timidity.cfg
++++ b/linuxconfig/timidity.cfg
+@@ -1,5 +1,5 @@
+ #on my debian: /usr/local/share/timidity/timidity.cfg
+-dir /home/user/eawpats/
++dir /usr/share/timidity/eawpatches
+ source gravis.cfg
+ source gsdrums.cfg
+ source gssfx.cfg
index 942dcdb38ee7055d655c01d21a5d0ad0d5c2c190..3c9b2827791e320fe6d2f8016d545b566abcf97a 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-S=${WORKDIR}/eawpats
+EAPI=7
 
 DESCRIPTION="Eric Welsh's GUS patches for TiMidity"
 HOMEPAGE="http://www.stardate.bc.ca/eawpatches/html/default.htm"
@@ -12,41 +10,32 @@ SRC_URI="http://5hdumat.samizdat.net/music/eawpats${PV}_full.tar.gz"
 LICENSE="free-noncomm"
 SLOT="0"
 KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 sparc x86"
-IUSE=""
+RESTRICT="binchecks strip"
 
 # These can be used for libmodplug too, so don't depend on timidity++
 DEPEND="app-eselect/eselect-timidity"
 RDEPEND=""
 
-RESTRICT="binchecks strip"
+S="${WORKDIR}/eawpats"
 
-src_unpack() {
-       unpack ${A}
-       sed -i -e "s:dir /home/user/eawpats/:dir /usr/share/timidity/eawpatches:" "${S}/linuxconfig/timidity.cfg"
-}
+PATCHES=( "${FILESDIR}"/${P}-fix-dir.patch )
 
 src_install() {
-       local instdir=/usr/share/timidity
+       # Install documentation, including subdirs
+       local f
+       while IFS="" read -d $'\0' -r f; do
+               dodoc "${f}"
+               rm "${f}" || die
+       done < <(find . -type f -name '*.txt' -print0)
 
        # Set our installation directory
-       insinto ${instdir}/eawpatches
+       insinto /usr/share/timidity/eawpatches
 
        # Install base timidity configuration for timidity-update
        doins linuxconfig/timidity.cfg
-       rm -rf linuxconfig/ winconfig/
-
-       # Install base eawpatches
-       doins *.cfg *.pat
-       rm *.cfg *.pat
+       rm -rf linuxconfig/ winconfig/ patref24.hlp ultrasnd.ini || die
 
-       # Install patches from subdirectories
-       for d in `find . -type f -name \*.pat | sed 's,/[^/]*$,,' | sort -u`; do
-               insinto ${instdir}/eawpatches/${d}
-               doins ${d}/*.pat
-       done
-
-       # Install documentation, including subdirs
-       dodoc $(find . -name \*.txt)
+       doins -r .
 }
 
 pkg_postinst() {