Bump to nut-12.2, bug 123755. Thanks to Michael Vogt for the ebuild
authorCharlie Shepherd <masterdriverz@gentoo.org>
Mon, 22 Jan 2007 23:48:11 +0000 (23:48 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Mon, 22 Jan 2007 23:48:11 +0000 (23:48 +0000)
Package-Manager: portage-2.1.2_rc4-r3

app-misc/nut/ChangeLog
app-misc/nut/files/digest-nut-12.2 [new file with mode: 0644]
app-misc/nut/nut-12.2.ebuild [new file with mode: 0644]

index 845592ff94c45f8717f124b798a55094ca7d1217..a6b49261ff9b105805087319eec95ce8027a63a2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-misc/nut
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.5 2005/10/04 13:39:26 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.6 2007/01/22 23:48:11 masterdriverz Exp $
+
+*nut-12.2 (22 Jan 2007)
+
+  22 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org> -nut-11.0.ebuild,
+  +nut-12.2.ebuild:
+  Bump to nut-12.2, bug 123755. Thanks to Michael Vogt for the ebuild
 
 *nut-11.0 (04 Oct 2005)
 
diff --git a/app-misc/nut/files/digest-nut-12.2 b/app-misc/nut/files/digest-nut-12.2
new file mode 100644 (file)
index 0000000..4ff19f4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6ebe22a2d002623de05d381bd75dbaff nut-12.2.tar.bz2 903328
+RMD160 12f59cb2e6220bb2de1dadcc822d686719bc1f4a nut-12.2.tar.bz2 903328
+SHA256 8d046b9da70b25eb1bd5605e3f7d8cd2b19915cfffb8a6b9e9d8a015af27f0af nut-12.2.tar.bz2 903328
diff --git a/app-misc/nut/nut-12.2.ebuild b/app-misc/nut/nut-12.2.ebuild
new file mode 100644 (file)
index 0000000..dce1c01
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-12.2.ebuild,v 1.1 2007/01/22 23:48:11 masterdriverz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://www.lafn.org/~av832/"
+SRC_URI="http://www.lafn.org/~av832/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+       append-flags '-DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/share/nut\"'
+       emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+       dodir /usr/share/nut
+       insinto /usr/share/nut
+       doins raw.data/*
+       dobin nut
+       doman nut.1
+}