dev-python/pycxx: 7.1.2 + EAPI 7 + py37/py38
authorSebastian Pipping <sping@gentoo.org>
Sun, 1 Mar 2020 13:49:03 +0000 (14:49 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sun, 1 Mar 2020 13:56:27 +0000 (14:56 +0100)
Closes: https://bugs.gentoo.org/602150
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

dev-python/pycxx/Manifest
dev-python/pycxx/pycxx-7.1.2.ebuild [new file with mode: 0644]

index f61d0aed18952b61a89fd58baa105859fcf8b172..bce88f507a96d9334482317e58bb58829b0ebe54 100644 (file)
@@ -1 +1,2 @@
 DIST pycxx-6.2.6.tar.gz 141547 BLAKE2B e067d2a3f7ce58200c3b97f971692f64545f224929308c6e9a668a15eb775580060e860cf8ba1f894ae61320aa3454622f15fcc6fbdc601251c9b9ce576b611d SHA512 9a6c30acb99c112497c02fb0826dc0197bbf4b813d25eab3f7d6537dfd83db8150c94f617f79810bbcca64496b8d6e67b1a41446523d66031c54c21e0425ea0c
+DIST pycxx-7.1.2.tar.gz 150865 BLAKE2B bbf78d88ca13fafee1239c354167b56cef2f1d56d20b0fc81d9a5d7d82096ab5d6a88802f411719cc490179314f87ef89b1e53c2b8a3a784566f9ff9d16d7cc8 SHA512 67f8d8d1ec6ce63c39695cd56c3276767d5cb4b6cc2fcf7daf5aea4bac11114f5a1fa4784ecdb35be708859cf07fc88c8e9f00b7fc808169708fd0eef1056a63
diff --git a/dev-python/pycxx/pycxx-7.1.2.ebuild b/dev-python/pycxx/pycxx-7.1.2.ebuild
new file mode 100644 (file)
index 0000000..d9581f7
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+       # Without this, pysvn fails.
+       # Src/Python3/cxxextensions.c: No such file or directory
+       sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( Doc/. )
+       use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+       distutils-r1_python_install_all
+}