dev-python/wstools: 0.4.8 + EAPI 7 + py38
authorSebastian Pipping <sping@gentoo.org>
Mon, 6 Apr 2020 11:07:05 +0000 (13:07 +0200)
committerSebastian Pipping <sping@gentoo.org>
Mon, 6 Apr 2020 11:07:05 +0000 (13:07 +0200)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/wstools/Manifest
dev-python/wstools/files/wstools-0.4.8-setup.patch [new file with mode: 0644]
dev-python/wstools/metadata.xml
dev-python/wstools/wstools-0.4.8.ebuild [new file with mode: 0644]

index 0c38a50cce85477cef27e3b8149aa315246c990f..57722218cc9bdd2484a2b603bb81b4195dcbc3fa 100644 (file)
@@ -1 +1,2 @@
 DIST wstools-0.4.5.tar.gz 201047 BLAKE2B 34c8d2c52ce9d1d67749ef6d0e1d5684a60718ef613688466d0992306f446b153d681b802fb142d1594bccaf37390495fb59e765f662e7550432d8866e038110 SHA512 24779bc2c2f3e32a515bc5690038e3f8e487fd45c1b7822d587e1bfd0bda660b837e3d5cbf8248459e06d7606e6d1c404dcee4de35b1f0d353bd5213e197d83a
+DIST wstools-0.4.8.tar.gz 199688 BLAKE2B 3b5137dd135ec8f0e6d69f94275d45367e609adb9763624fcabb899f84c6215c2df26485dcf32d44d6683bd97cd00e2d283cf9096b6f58414f2eacd9e8b93a4a SHA512 0f86e91a2de7333aaf5a58558a715edd6a0cf97150f6d0cae4ecf8e0702648a98e610aa6d3295444079bd616656efcb2823ae7c02c5c3ffcb4789548ac40cd0a
diff --git a/dev-python/wstools/files/wstools-0.4.8-setup.patch b/dev-python/wstools/files/wstools-0.4.8-setup.patch
new file mode 100644 (file)
index 0000000..3d8c168
--- /dev/null
@@ -0,0 +1,25 @@
+From eb57ef5ad6abeaf8d9daf4914f95bcd86670340a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 6 Apr 2020 13:00:31 +0200
+Subject: [PATCH] Drop dependency on pytest-runner
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index d9887a8..8a63a13 100644
+--- a/setup.py
++++ b/setup.py
+@@ -29,7 +29,7 @@ class PyTest(TestCommand):
+ setuptools.setup(
+-    setup_requires=['pbr>=1.10', 'setuptools>=17.1', 'pytest-runner'],
++    setup_requires=['pbr>=1.10', 'setuptools>=17.1'],
+     pbr=True,
+     cmdclass={'test': PyTest},
+     test_suite='tests')
+-- 
+2.24.1
+
index deddbf3b3cd8cf0b7508bb1a596ade65217e6334..59b345f0b6c2a419f7e8966b34289c779b8595b7 100644 (file)
@@ -8,6 +8,6 @@
   <stabilize-allarches/>
   <upstream>
     <remote-id type="pypi">wstools</remote-id>
-    <remote-id type="github">kiorky/wstools</remote-id>
+    <remote-id type="github">pycontribs/wstools</remote-id>
   </upstream>
 </pkgmetadata>
diff --git a/dev-python/wstools/wstools-0.4.8.ebuild b/dev-python/wstools/wstools-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..857203d
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/pycontribs/wstools https://pypi.org/project/wstools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+       ${RDEPEND}
+       dev-python/pbr[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.8-setup.patch )
+
+distutils_enable_tests pytest