app-text/robodoc: revision to build against musl
authorOvidiu-Dan Bogat <4z0r@ovidiu.at>
Sat, 21 Mar 2020 15:07:51 +0000 (16:07 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 25 Mar 2020 13:45:24 +0000 (15:45 +0200)
Closes: https://bugs.gentoo.org/713616
Signed-off-by: Ovidiu-Dan Bogat <ovi@ovidiu.at>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/15035
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-text/robodoc/files/robodoc-4.99.43_clean_libc.patch [new file with mode: 0644]
app-text/robodoc/robodoc-4.99.43-r1.ebuild [new file with mode: 0644]

diff --git a/app-text/robodoc/files/robodoc-4.99.43_clean_libc.patch b/app-text/robodoc/files/robodoc-4.99.43_clean_libc.patch
new file mode 100644 (file)
index 0000000..db2b112
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/Source/troff_generator.c b/Source/troff_generator.c
+index 1b123b8..94ddcda 100644
+--- a/Source/troff_generator.c
++++ b/Source/troff_generator.c
+@@ -30,7 +30,7 @@ along with this program.  If not, see <http://www.gnu.org/licenses/>.
+ #include <ctype.h>
+ #include <sys/param.h>
+-#include <sys/unistd.h>
++#include <unistd.h>
+ #include "troff_generator.h"
+ #include "util.h"
diff --git a/app-text/robodoc/robodoc-4.99.43-r1.ebuild b/app-text/robodoc/robodoc-4.99.43-r1.ebuild
new file mode 100644 (file)
index 0000000..483fe44
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Automating Software Documentation"
+HOMEPAGE="https://www.xs4all.nl/~rfsber/Robo/robodoc.html"
+SRC_URI="https://rfsber.home.xs4all.nl/Robo/archives/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+PATCHES=(
+       "${FILESDIR}/${P}_clean_libc.patch"
+       )
+
+RDEPEND=">=dev-util/ctags-5.3.1"
+DEPEND="${RDEPEND}"
+
+src_install() {
+       default
+
+       insinto /usr/share/${PN}
+       doins Contributions/*
+
+       if use examples; then
+               insinto /usr/share/${PN}
+               doins -r Examples/PerlExample
+       fi
+}