Fix *initd, *confd and *envd calls (#173884, #174266)
authorTorsten Veller <tove@gentoo.org>
Sun, 29 Apr 2007 17:39:43 +0000 (17:39 +0000)
committerTorsten Veller <tove@gentoo.org>
Sun, 29 Apr 2007 17:39:43 +0000 (17:39 +0000)
Package-Manager: portage-2.1.2.5

net-fs/autofs/ChangeLog
net-fs/autofs/autofs-4.1.3-r7.ebuild
net-fs/sfs/ChangeLog
net-fs/sfs/sfs-0.7.2.ebuild

index b03530f5e90d0f09894a4a49730c0f7671720fd6..593bdb567d05301a89f6b6d1a623aec59c4d9dc5 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-fs/autofs
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.61 2007/02/22 02:10:51 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.62 2007/04/29 17:39:43 tove Exp $
+
+  29 Apr 2007; Torsten Veller <tove@gentoo.org> autofs-4.1.3-r7.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
index 2139f2fbdafffdb8e3258d95a401c3df2be0ddad..ca938b89f3f59c7694c4feb3bc32fbb1e273f0e5 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.1.3-r7.ebuild,v 1.3 2006/11/25 14:32:02 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.1.3-r7.ebuild,v 1.4 2007/04/29 17:39:43 tove Exp $
 
 inherit eutils multilib
 
@@ -66,13 +66,12 @@ src_install() {
        sed -i 's:\/etc\/:\/etc\/autofs\/:g' *.8 *.5 *.in || die "Failed to update path in manpages"
        doman auto.master.5 autofs.5 autofs.8 automount.8
 
-       dodir /etc/autofs /etc/init.d /etc/conf.d
        insinto /etc/autofs ; doins ${FILESDIR}/auto.master
        insinto /etc/autofs ; doins ${FILESDIR}/auto.misc
        exeinto /etc/autofs ; doexe ${FILESDIR}/auto.net # chmod 755 is important!
 
-       exeinto /etc/init.d ; newexe ${FILESDIR}/autofs.rc11 autofs
-       insinto /etc/conf.d ; newins ${FILESDIR}/autofs.confd9 autofs
+       newinitd ${FILESDIR}/autofs.rc11 autofs
+       newconfd ${FILESDIR}/autofs.confd9 autofs
        if use ldap; then
                cd ${S}/samples
                docinto samples ; dodoc ldap* auto.master.ldap
index 6a4a29ad2523f117642cbaf1ff4d7f48c4937cef..711fbfa8c116c02b2f0585bff67645a2cbd14e9f 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-fs/sfs
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/ChangeLog,v 1.13 2007/02/22 02:13:06 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/ChangeLog,v 1.14 2007/04/29 17:35:14 tove Exp $
+
+  29 Apr 2007; Torsten Veller <tove@gentoo.org> sfs-0.7.2.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
index 2a86b1a708ac85c40de06b6d88c842a736587b1a..db97df0c89c0f3224fff54467b66b7278fc78e51 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/sfs-0.7.2.ebuild,v 1.15 2006/03/06 20:51:59 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/sfs-0.7.2.ebuild,v 1.16 2007/04/29 17:35:14 tove Exp $
 
 inherit eutils
 
@@ -63,8 +63,7 @@ src_install() {
                README README.0.7-upgrade \
                STANDARDS TODO
 
-       exeinto /etc/init.d/
-       doexe ${FILESDIR}/sfscd \
+       doinitd ${FILESDIR}/sfscd \
                ${FILESDIR}/sfssd
 
        dosym /lib/${P}/newaid /bin/newaid