version bump (bug #560912)
authorMichael Sterrett <mr_bones_@gentoo.org>
Mon, 21 Sep 2015 02:21:44 +0000 (22:21 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Mon, 21 Sep 2015 02:22:09 +0000 (22:22 -0400)
Package-Manager: portage-2.2.20.1

games-util/antimicro/Manifest
games-util/antimicro/antimicro-2.19.2.ebuild [new file with mode: 0644]

index 6e76321cfe05483884e6c328bc40897fd18b561e..75a1c4c9ee320fcbb98120946a95f542723ca0ad 100644 (file)
@@ -1 +1,2 @@
 DIST antimicro-2.10.1.tar.gz 662670 SHA256 9a65127dc415017dd2c84f06a4c803d6353a1c6a129a2f9a30791cffce0378b4 SHA512 0601ae0ea2bb7249e0bb7fdf12a9d023058bf37fde2f7dc350676d3a0b757ad29e43b5f1c8fd0c4600207338a755f12640ea8b5c8e762f01d528364048326ddf WHIRLPOOL 2e5d32a9bf2e05838111786ceb0f7646b457f4e9042cc99a6aaa79cdcacefacdd9d4698ab42870c6eb97f735f2bb99d904e45d168a34acf87bc0f97524b3eeb0
+DIST antimicro-2.19.2.tar.gz 1028594 SHA256 039dd006aa8f8b2f4162ec6e03599aaf2d52523620542915aa7baabe74b8959d SHA512 1e68b2cde2c60765af81ae4eed25787698dc18c699e19371bceaf805fcb97f0166dc5345c70f695f5488f872de28f43bf664f238640eff2343e1d19231ff7df1 WHIRLPOOL e358d8eb7fcffe1e54b1ade0dadbb69b8d2bbad0ec22e25cfbd3c38975a2f46002a4da3f7ee06ee066646c1992c0bd5ebcd6da5a7c1a1a26ea7c5bf729305e7d
diff --git a/games-util/antimicro/antimicro-2.19.2.ebuild b/games-util/antimicro/antimicro-2.19.2.ebuild
new file mode 100644 (file)
index 0000000..54de935
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils
+
+DESCRIPTION="Map keyboard and mouse buttons to gamepad buttons"
+HOMEPAGE="https://github.com/Ryochan7/antimicro"
+SRC_URI="https://github.com/Ryochan7/antimicro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtnetwork:5
+       dev-qt/linguist-tools:5
+       media-libs/libsdl2[X,joystick]
+       x11-libs/libX11
+       x11-libs/libXtst"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_configure() {
+       local mycmakeargs=(
+               -DUSE_SDL_2=ON
+       )
+
+       QT_SELECT=5 cmake-utils_src_configure
+}