sys-kernel/pf-sources: bump to 5.2-pf4
authorJoonas Niilola <juippis@gentoo.org>
Sun, 4 Aug 2019 15:39:10 +0000 (18:39 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 4 Aug 2019 15:39:10 +0000 (18:39 +0300)
Package-Manager: Portage-2.3.70, Repoman-2.3.16
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-kernel/pf-sources/Manifest
sys-kernel/pf-sources/pf-sources-5.2_p4.ebuild [new file with mode: 0644]

index c04d77c35034c18726ee841020916298d29840b5..db03469390a9cb5bd7821bb09e5db45dbfcd1956 100644 (file)
@@ -10,3 +10,4 @@ DIST pf-sources-5.1_p7.patch 2206844 BLAKE2B 542a9c09aa1e9def85afafe4f6275aa62c1
 DIST pf-sources-5.2_p1.patch 365922 BLAKE2B dee7af932e0e220b4493a09adc21b210439705a615333e0fef91ffb577aa489f133864742f50b926266c9e939d9780ac5f587c4c518e15669cad866c38d90a34 SHA512 b518678bbabedc25e72716ebbe1afa4599ebc46d4eb3ee3ed8ae815ecbf64ea0cafe1dde9e5b5b72898b17758972ed5fca37f71a45f774a2922ce7deead15f2d
 DIST pf-sources-5.2_p2.patch 556688 BLAKE2B cbcfc2b0949386e72a5bfe2a7e4eb5fe56a38c2a451e631509f31b61e3492150f5177e97390d1945959026188ef62c5e90a7474f9d26b5a63d920a1136b350f3 SHA512 2a74dac88e2e5828e44576041223e3168ac980fa6ff01819bdbd5f626cd233d4571641bffe176c0738fbfb2d8aefbe1f8e91990e4aa95e6587eea91983582db7
 DIST pf-sources-5.2_p3.patch 1101135 BLAKE2B f56ff7a269e48513ac2d8360531eef0b60b0d86ec3af223729870c3461746aef1f7370a6448558e921bfacf345043ca4f97d56c1f8069d5a6f607f9cb615e096 SHA512 0b81cf9927bcec69910f18046ccfead4ad3072e8926315f7eed122edd09ca87c43d345402051249f55de2f98c12b04bd87096653051eb1dc77e27fe24c2e85f3
+DIST pf-sources-5.2_p4.patch 1370761 BLAKE2B 54a489784bdfa42879931eb5f05d4ee91bccb9b8b755bc4a3a1221259f5d16df12b1bb240518f8ee86b93383f8ec2f5eb29541548c5d4ca6d4d3aa41b1b92dc2 SHA512 4489218cd370cb38cda5c79b05d26e7150ac8ce97eaf0a03013743f9507fff82cd1024e0f95e226bd5d1f3c4741a5ab8934002e4a0c0e13fc2666513b41b6491
diff --git a/sys-kernel/pf-sources/pf-sources-5.2_p4.ebuild b/sys-kernel/pf-sources/pf-sources-5.2_p4.ebuild
new file mode 100644 (file)
index 0000000..9035be3
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+ETYPE="sources"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="
+       https://gitlab.com/post-factum/pf-kernel/wikis/README
+       https://dev.gentoo.org/~mpagano/genpatches/
+"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+       ${KERNEL_URI}
+       ${PF_URI}
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+       "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+       ewarn
+       ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+       ewarn "If you need support, please contact the pf developers directly."
+       ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+       ewarn "the ebuilds. Thank you."
+       ewarn
+       kernel-2_pkg_setup
+}
+
+src_prepare() {
+       default
+       kernel-2_src_prepare
+}